none
Vista Ultimate .net Framework 3.5 sp1 Installation RRS feed

  • General discussion

  • Hi
     
    I read all logs and blogs during the last couple of days.

    I installed Vista Ultimate as a fresh copy. No debug version.
    I run the cleanup tools before installing the .net 3.5 sp1
    I made sure that some .net 3.0 or IIS checkboxes are ticked
    I used the .net checker to ensure 2.0 SP1, 3.0 SP1 and 3.5 is installed
    I tried the .net sp1 3.5 web package
    I tried the .net sp1 3.5 full package
    I tried the Visual Studio 2008 full package and the Visual Studio SP 1 failed because .net 3.5 sp1 is part of it.
    I unpacked the .net 3.5 SP1 and installed only the KB948609 and it failed.
    I tracked down the error and found the same log entries as million of users in the world wide web:

    dd_dotnetfx35error:
    [02/23/09,23:37:31] Microsoft .NET Framework 2.0SP1 (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 2.0SP1 (CBS). MSI returned error code 14101
    [02/23/09,23:38:12] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0SP1 (CBS) is not installed.

    WindowsUpdateLog for KB 948609:

    2009-02-24             07:56:37:147          5276        fc4           Handler   CBS package identity: Package_for_KB948609~31bf3856ad364e35~x86~~6.0.6001.3053

    2009-02-24             07:56:37:475          5276        fc4           Handler   Installing self-contained with source=C:\Windows\SoftwareDistribution\Download\a57d8c2cdacc1611e15ae4a8cfd6b966\Windows6.0-KB948609-v6001-x86.cab, workingdir=C:\Windows\SoftwareDistribution\Download\a57d8c2cdacc1611e15ae4a8cfd6b966\inst

    2009-02-24             07:58:04:626          5276        1484        Handler   FATAL: CBS called Error with 0x80073715,

    2009-02-24             07:58:08:073          5276        fc4           Handler   FATAL: Completed install of CBS update with type=0, requiresReboot=0, installerError=1, hr=0x80073715

    CBS-Log:

    2009-02-24 07:57:56, Info                  CSI    00000048 Performing 1 operations; 1 are not lock/unlock and follow:

      Stage (1): flags: 8 app: [0fc1f415e1f35145b6edd989343746b1, Version = 6.0.6001.18111, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:b03f5f7f11d50a3a}, Type neutral, TypeName neutral, PublicKey neutral]) comp: (null) man: @0x3c2fe14

    2009-02-24 07:57:56, Info                  CSI    00000049 Stage component failed, manifest does not match previously staged manifest for identity

    2009-02-24 07:57:56, Error                 CSI    0000004a@2009/2/24:06:57:56.841 (F) d:\rtm\base\wcp\componentstore\csd_transact.cpp(1358): Error STATUS_SXS_MANIFEST_IDENTITY_SAME_BUT_CONTENTS_DIFFERENT originated in function CCSDirectTransaction::StageComponent expression: (null)

    [gle=0x80004005]

    2009-02-24 07:58:03, Error                 CSI    0000004b (F) STATUS_SXS_MANIFEST_IDENTITY_SAME_BUT_CONTENTS_DIFFERENT #80299# from CCSDirectTransaction::OperateEnding at index 0 of 1 operations, disposition 2[gle=0xd015001c]

    2009-02-24 07:58:03, Error                 CSI    0000004c (F) HRESULT_FROM_WIN32(ERROR_SXS_MANIFEST_IDENTITY_SAME_BUT_CONTENTS_DIFFERENT) #79768# from Windows::ServicingAPI::CCSITransaction::ICSITransaction_PinDeployment(Flags = 0, a = 0fc1f415e1f35145b6edd989343746b1, Version = 6.0.6001.18111, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:b03f5f7f11d50a3a}, Type neutral, TypeName neutral, PublicKey neutral, cb = (null), s = (null), rid = [80]"Package_1_for_KB948609~31bf3856ad364e35~x86~~6.0.6001.3053.948609-32_neutral_GDR", rah = [2]"16", manpath = [182]"\\?\C:\Windows\SoftwareDistribution\Download\a57d8c2cdacc1611e15ae4a8cfd6b966\inst\x86_0fc1f415e1f35145b6edd989343746b1_b03f5f7f11d50a3a_6.0.6001.18111_none_7525fc8e949d1ba7.manifest", catpath = [145]"\\?\C:\Windows\SoftwareDistribution\Download\a57d8c2cdacc1611e15ae4a8cfd6b966\inst\Package_1_for_KB948609~31bf3856ad364e35~x86~~6.0.6001.3053.cat", ed = 0, disp = 0)[gle=0x80073715]

    2009-02-24 07:58:03, Info                  CSI    0000004d@2009/2/24:06:58:03.627 CSI Transaction @0x6e7cbe8 destroyed

    2009-02-24 07:58:03, Info                  CBS    WER: Generating failure report for package: Package_for_KB948609~31bf3856ad364e35~x86~~6.0.6001.3053, status: 0x80073715, failure source: Resolve, start state: 0, target state: 7

    2009-02-24 07:58:04, Info                  CBS    Exec: Processing complete.  Session: 29988429:156966475, Package: Package_for_KB948609~31bf3856ad364e35~x86~~6.0.6001.3053, hr: 0x80073715

    2009-02-24 07:58:04, Info                  CBS    Exec: End: nested restore point - complete.



    I am not a professional developer so it's hard for me to solve this issue but can somebody explain to me what the last error in the cbs.log means.

    Thanks in advance

    Joachim
    Thursday, February 26, 2009 8:00 AM

All replies

  •  Hi an update from my side. I found smilair errors in the checksur.log file.

    (f) CSI Manifest All Zeros 0x00000000 
    WinSxS\Manifests\x86_netfx-sys_enterpriseservices_tlb_b03f5f7f11d50a3a_6.0.6001.22230_none_04ff45c57bb6178a.manifest x86_netfx-sys_enterpriseservices_tlb_b03f5f7f11d50a3a_6.0.6001.22230_none_04ff45c57bb6178a 
    (f) CSI Manifest All Zeros 0x00000000 WinSxS\Manifests\x86_4292f0f8a4a7c15058123e3c2692c6d4_b03f5f7f11d50a3a_6.0.6001.22230_none_0147e0fecae161e4.manifest x86_4292f0f8a4a7c15058123e3c2692c6d4_b03f5f7f11d50a3a_6.0.6001.22230_none_0147e0fecae161e4 
    (f) CSI Manifest All Zeros 0x00000000 WinSxS\Manifests\x86_0fc1f415e1f35145b6edd989343746b1_b03f5f7f11d50a3a_6.0.6001.18111_none_7525fc8e949d1ba7.manifest x86_0fc1f415e1f35145b6edd989343746b1_b03f5f7f11d50a3a_6.0.6001.18111_none_7525fc8e949d1ba7 
    (f) CSI Manifest All Zeros 0x00000000 WinSxS\Manifests\x86_netfx-system_drawing_tlb_b03f5f7f11d50a3a_6.0.6001.18111_none_e239005e92b831fe.manifest x86_netfx-system_drawing_tlb_b03f5f7f11d50a3a_6.0.6001.18111_none_e239005e92b831fe

    Confused that nobody can at least explain where these error come from.

    Cheers
    Monday, March 2, 2009 9:48 PM