none
Material Resource type causing the queue to fail. RRS feed

  • Question

  • Hi :

    This is for Project Server 2007. I have created a Material Resource for the travel expense.  I am using PSI to update the cost to track actual expense.   I created a backup project for the actual production project.  In my test project, I deleted all the assigned resources and used my test user.  My test user never had any work assign to the live project.  I was able to update material expense with no issue.  I even tried to add an actual user to the assignment.  My actual user had all kind of projects that are assigned to him.  It works properly for the test project.  But when I tried the production project.  I basically get the catch all error for 26000.  I am basically updating the same task.  My test project works but not the production one.  Is there something about Material expense type that I need to be aware of? 

    <?xml version="1.0" encoding="utf-16"?>

    <errinfo>

      <dataset name="ProjectDataSet">

        <table name="Assignment">

          <row ASSN_UID="20edf802-267e-494e-8f73-cc9129e153cb" PROJ_UID="4a50f028-41b9-47f5-bcd1-00edf19d1a51">

            <error id="135" name="AssignmentCannotEditSummaryTask" uid="0bbfcc75-5545-4801-a7c4-b4e98605a157" />

          </row>

        </table>

      </dataset>

      <general>

        <class name="Queue">

          <error id="26000" name="GeneralQueueJobFailed" uid="22a0fee9-0688-45af-a943-ac073755d144" JobUID="a8f7227c-f4fd-4b3f-8bf6-7930aad658d9" ComputerName="xxx" GroupType="ProjectUpdate" MessageType="" MessageId="" Stage="" />

        </class>

      </general>

    </errinfo>

    Thanks for your assistance,

    kkmick

    Wednesday, November 24, 2010 8:24 PM

All replies

  • Hi kkmick - the error appears to be more related to the assignment type than the resource type.  Does you test project also try and edit a summary task?  <error id="135" name="AssignmentCannotEditSummaryTask" uid="0bbfcc75-5545-4801-a7c4-b4e98605a157" />

    Best regards,

    Brian.


    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page
    Tuesday, November 30, 2010 10:36 PM
    Owner
  • Hi Brian:

    I am trying to update the material exepnse the unit cost within an assignment.  It is not a summary task.  I don't know if this will cause an issue or not.  At one point this project had cost resource in it.  And we were trying to update cost using psi.   Then when we find out cost resources  does not work well with work resources.  We went and delete all the cost resources  from the project totally.  That should not be an issue any further. 

    Thanks,

    kkmick

    Wednesday, December 1, 2010 2:56 PM