none
Problem with Hyper-V RRS feed

  • Question

  • Hello NG,
    I use Windows 10 Pro, 64 bit, on an Intel Core i5-2540M 2.6 GHz.
    In Hyper-V-Manager I get the following error when trying to connect to a "server":


    Error message:
    << Failed to connect to server "<Computerame>". Make sure the administrative service
    Is running on virtual machines and you are authorized to connect to the server.
    The Hyper-V administration tools did not allow access to an expected WMI class on computer "<Computerame>".
    This may indicate that the Hyper-V platform is not installed on the computer or that is the version of the Hyper-V platform
    Hyper-V platform is not compatible with these management tools

    Can someone give me a tip for a solution?
    Thank you in advance.

    Michael Abendroth

    Friday, January 6, 2017 10:10 AM

All replies

  • local Hyper-V, remote Hyper-V?

    In the same domain? (usually works).

    Is it Hyper-V 2012 or newer?

    https://technet.microsoft.com/windows-server-docs/compute/hyper-v/manage/remotely-manage-hyper-v-hosts


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.

    Friday, January 6, 2017 3:58 PM
    Moderator
  • Hello Brian,

    thank You for answering.

    I use it on a local computer.

    I do not know which version of Hyper-v I use. It is the version that is included with Windows 10.


    I do not know which version of Hyper-v I use. It is the version that is included with Windows 10.
    I do not know which version of Hyper-v I use. It is the version that is included with Windows 10.
    Friday, January 6, 2017 7:05 PM
  • Windows 10 includes the version of Hyper-V for Windows 10 / Server 2016.

    Assuming that you added Hyper-V the Role and not simply Hyper-V the Remote Server Management Tools it should - 'just work' for a local install.

    If you are using PowerShell, you will need an elevated prompt.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.

    Friday, January 6, 2017 7:13 PM
    Moderator
  • I'm assumimg youre pc/server is in an workgroup enviorment? Use the following steps will do the trick o Client with Hyper-V Manager o Server with the Hyper-V role enabled. o Both systems are in the same workgroup called “workgroup” o Both systems have the same username and password. Configuration on the Hyper-V server: • Enable Remote Management 1 Configure-SMRemoting.exe -Enable • Open firewall for Remote Computer Management 1 2 Set-NetFirewallRule -DisplayGroup 'Windows Management Instrumentation (WMI)' -Enabled true -PassThru Set-NetFirewallRule -DisplayGroup 'Remote Event Log Management' -Enabled true -PassThru • Open firewall for ping (ICMPv4) 1 Set-NetFirewallRule -DisplayName “File and Printer Sharing (Echo Request – ICMPv4-In)” -Enabled True -PassThru • Enable Remote Desktop and allow remote connections 1 cscript.exe c:\Windows\System32\SCregEdit.wsf /AR 0 • Enable Remote disk management 1 Set-NetFirewallRule -DisplayGroup 'Remote Volume Management' -Enabled true -PassThru Configuration on the client: • Create a host file with IP address and hostname of the server. Make sure you can ping the hostname • Make sure that the network type is part of a private network before executing the WINRM command • Enable Remote Management 1 winrm quickconfig • For Managing remote systems 1 winrm set winrm/config/client @{TrustedHosts="Name of the Server"} • Enable remote disk Management (add this command on both systems) firewall rule 1 Set-NetFirewallRule -DisplayGroup 'Remote Volume Management' -Enabled true -PassThru • Open c:\windows\system32\dcomcnfg.exe and allow ‘anonymous logon’ for local and remote access. After making this settings You can manage the Hyper-V server with the following tools remotely: • Hyper-V manager • Computer Management • Disk Management
    Saturday, January 7, 2017 8:36 AM
  • Hello Brian,
    I solved the problem. The Hyper-V services were not installed correctly.
    Many thanks for the support.
    Michael

    • Edited by Abendroth-M Saturday, January 7, 2017 2:28 PM
    Saturday, January 7, 2017 2:27 PM
  • Youre welcome
    Saturday, January 7, 2017 2:31 PM
  • How did you know that the services weren't installed correctly and what did you do to fix it? I'm running into the same issue after I did the Windows 10 Upgrade.
    Thursday, April 27, 2017 11:43 PM
  • Dear Abendroth-M
    I ran into the same problem an I would like to kindly explain how you installed the services correctly?
    Many thanks
    Thursday, May 18, 2017 8:39 AM
  • I ran into the same problem; I found out that I didn't have Hyper-V Platform checked;

    It is under Control Panels > Programs and Features > Turn Windows features on or off >

    Hyper-V > then make sure to check both boxes [ Hyper-V Mgmt Tools and Hyper-V Platform]; 

    Then reboot :)

    Note: you might need to go to BIOS and enable Virtualization; since i have an HP EliteDesk 800 G1, in BIOS:

    Boot PC and hit F10 > System Security > Virtualization Technology (VTx) (enable/disable) and Virtualization Technology Directed I/O (VTd) (enable/disable) <<-----enable both!

    Wednesday, July 18, 2018 11:00 PM