locked
I'm finding the code formatting within these forums unusable -just me? RRS feed

  • Question

  • User447 posted

    Trying to add a code segment the forum gives me '' to insert my code into but the problem is I want to insert muliple lines of code into a single snippet and it doesn't seem to work properly.

    Is it just me?

    Wednesday, February 20, 2013 9:29 PM

All replies

  • User9 posted

    It seems better to use the indent approach instead of the '' formatting, especially for multi-line code snippets, that's what I always use.

    Wednesday, February 20, 2013 9:31 PM
  • User48 posted

    The code button is context-dependent. If you select a few words within a line, or your "whole line" selection doesn't include a newline, clicking the code button will wrap in backticks.

    If you select multiple lines, including newlines, then clicking the code button will indent the lines.

    That doesn't explain the sheer number of people who paste large amounts of text and then have every line individually wrapped in backticks...

    Wednesday, February 20, 2013 10:02 PM
  • User447 posted

    Ok, just testing..

                    if (TableExists("Employee", conn)) conn.CreateTable<Employee>();
                    if (TableExists("JobCode", conn)) conn.CreateTable<JobCode>();
    
    Wednesday, February 20, 2013 10:25 PM
  • User447 posted

    I see.. I had it all wrong! I was clicking the code button THEN pasting in my code. Thanks jonp.

    Wednesday, February 20, 2013 10:26 PM