locked
visual studio test professional 2012 RRS feed

  • Question

    • I have recently started using MTM and am having issues with the action recording playback feature. I start my recordings by launching a new IE 11 browser and .i have created shared steps for open the browser and launch the url first i recorded the action for my shared steps then continued my recording .However, when I replay the recordings I have experienced  the shared steps played correctly after that i got error like 

                Playback action failed

                Failed action:click custom controlled

                Error:Unable to find Windows Internet Explorer with 'Sessions| CCJS Internet Explorer - Windows Internet Explorer' in the title.

    Thursday, June 5, 2014 9:08 AM

Answers

  • Hi,

    I just updated my visual studio,so problems in shared step and playback resolved automatically.

    • Marked as answer by Amanda Zhu Wednesday, June 11, 2014 1:28 AM
    Tuesday, June 10, 2014 7:47 AM

All replies

  • Hi,

    Based on your post, I assume that all recorded actions were in a Shared Steps and those recorded actions played back correctly but you got an error after the Shared Steps was played back. If I understood correctly, according to the error message, it seems that one actions failed to play back, whether you recorded the action: click custom controlled? Whether the Windows Internet Explorer with 'Sessions| CCJS Internet Explorer - Windows Internet Explorer' existed after the shared steps was replayed?

    I suggest re-creating a Shared Steps and recording actions for it and then play back those actions to check the result.

    Another way to troubleshoot this issue is creating a Coded UI test for those actions on another machine with VS Ultimate/Premium and run the test to check whether you can get the same issue.

    Thanks,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, June 6, 2014 2:24 AM
  • Hi,

    What about your issue now?

    If you have resolved it, you can share the solution here, which will be beneficial for other members with the same issue.

    If you did not, please tell us the result of my suggestion, I will try my best to help you.

    Best regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, June 10, 2014 1:39 AM
  • Hi,

    Glad to see the original issue has been resolved. How did you resolve it? Could you share us the solution here? It will be beneficial for other members with the similar issue.

    As for your new issue, could you please open a new thread for it on Coded UI test forum since you can get same issue when you do test with coded UI? If coded UI test can't support angular single page app, then MTM does not support it. Generally one thread discusses one issue. And please post the detailed error messages and you application in that thread so that experts there can help you better.

    Thanks


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, June 10, 2014 5:50 AM
  • Hi,

    I just updated my visual studio,so problems in shared step and playback resolved automatically.

    • Marked as answer by Amanda Zhu Wednesday, June 11, 2014 1:28 AM
    Tuesday, June 10, 2014 7:47 AM