none
Unable to get property 'currentFrameData error in Bing map V8 RRS feed

  • Question

  • Hi,

    We are getting below error when we tried remove the layer or zoomin/zoomout the map.  

    Unable to get property 'currentFrameData'  

    Can anyone have solution for this issue.

    Thanks!


    Balasaheb

    Friday, December 9, 2016 1:44 PM

Answers

All replies

  • Hi,

    Any update for our above issue. Anyone get any solution for it.

    Thanks!


    Balasaheb

    Monday, December 12, 2016 1:13 PM
  • I have tried a bunch of different apps and I'm not able to reproduce this. Can you provide details around the steps you are doing to create this error. I've seen this error once before when using the drawing tools module and there is a know error there. You and I discussed this here: https://social.msdn.microsoft.com/Forums/en-US/7052c4d0-56b2-4bf3-9039-61baad465b9f/bing-map-v8-drawing-shape-question?forum=bingmaps

    [Blog] [twitter] [LinkedIn]

    Monday, December 12, 2016 1:53 PM
  • Hi Ricky,

    We are getting the "currentFrameData" once again.

    The issue is same explain in below link

    https://social.msdn.microsoft.com/Forums/en-US/91897a77-6d84-4473-a927-b690dcb49554/layersremove-causes-unable-to-get-property-currentframedata-of-undefined-or-null-reference?forum=bingmapsajax

    One more thing when we try to clear the layer then it throws following error.

    can not read property ''length' of undefined. but it clear the layers. 

    Can you please check and let us know the cause of it and how to resolve it.

    Thanks!


    Balasaheb


    Friday, January 27, 2017 3:44 AM
  • Are you using the Drawing Tools module? If so, create your layers after loading the Drawing Tools module. There is a known issue with the module at the moment with layers that are created before this module is loaded. Basically, the drawing tools module modifies the layer class when it is loaded and this modification is causing issues in previously created layers. The team plans to fix this issue, but have a number of other issues and tasks they need to address at the moment.

    [Blog] [twitter] [LinkedIn]

    Friday, January 27, 2017 6:23 PM
  • Hi Ricky,

    We are facing above issue once again. More info on that.

    We plotting multiple pushpin say 100 in one layer and then plot another special pushpin with another layer and then plot other pushpin in another layer. When we try to hide/show layers basis on some condition then we are getting above issue.

    Can you please confirm anything we are missing here. 

    Thanks!

      


    Balasaheb

    Saturday, March 4, 2017 2:18 PM
  • I'm not aware of any recent changes. Can you try pointing to the experimental branch to see if the issue still occurs. I believe a fix for the original issue with layering and drawing tools has just been checked into the experimental branch.

    [Blog] [twitter] [LinkedIn]

    Saturday, March 4, 2017 4:19 PM
  • Hi Ricky,

    We have checked and found below error in console. As said eralier we got this error when we tried to hide/show pushpin layer. Here no drawing tool exist.

    Can you please let us know exact cause of this issue.

    Thanks! 


    Balasaheb

    Sunday, March 12, 2017 12:56 PM
  • I'm not able to reproduce this issue. Here is a code sample I put together that hides/shows layers based on the zoom level which appears to be working fine: http://bingmapsv8samples.azurewebsites.net/#Limit%20Layer%20to%20Zoom%20Range

    Can you provide more information on how you are hide/showing the error and how you are adding the layers to the map.


    [Blog] [twitter] [LinkedIn]


    Sunday, March 12, 2017 7:38 PM
  •  

    Hi Ricky,

    Recently we faced  Cannot read property "currentFrameData" of undefined issue as shown in below screenshot.


    Once it start to comong then nothing is working until we refresh whole page.

    Here is more detail. We have one check to plot pushpin or cluster. When cluster checked we plot using cluster and when we checked pushpin we plot using psuhpin. When we tried to switch beetween pushpin and cluster then some time it throws currentFrameData error after that noting is working and this is is random.

    Can you please let us know what is the cause of this issue and how to resolve it.

    Thanks!




    Balasaheb

    Wednesday, June 14, 2017 2:28 PM
  • I had this issue for the last two days. I fixed it by inserting the layer on the map before I added any pushpins to it.


    WeDoMapping

    Thursday, June 15, 2017 2:43 PM
  • Hi,

    We have tried above method, but still we face same issue. Is there any other way to resolve this issue.

    Thanks!


    Balasaheb

    Tuesday, July 4, 2017 3:03 PM
  • Hi,

    Can anyone have solution for it.

    Thanks!


    Balasaheb

    Friday, July 7, 2017 1:35 PM
  • Can you provide a code sample that reproduces this issue. Which browser are you using? We haven't been able to reproduce this issue.

    [Blog] [twitter] [LinkedIn]

    Tuesday, July 11, 2017 5:55 PM
  • Hi Ricky,

    We are ploting pushpin and then draw the shape using drawing manager and then try to hide/show pushpin based on condition. We use the code that given in bing map SDK.

    We are uisng Google chrome.

    Thanks!


    Balasaheb

    Wednesday, July 12, 2017 5:10 AM
  • I need sample code or a link to a test site that reproduces this. I've tried about 15 different code samples that try to mimic what you are explaining and all of them work 100% and don't throw an error. 

    [Blog] [twitter] [LinkedIn]

    Wednesday, July 12, 2017 6:05 PM
  • hi Balasaheb,

    I have faced same issue and i have resolved this issue.this issue is related to layer instantiate, in my case the cause of this issue is pushpin and polyline insertion in layer and then layer insertion in map at wrong place in code like in loop expatiation: i have instantiated layer once and adding layer with pushpin in loop multiple time after correcting this issue it is working fine.

    Thanks

    Nilesh Patel

    Friday, August 18, 2017 12:49 PM