locked
Backup Error filling up hard disk space RRS feed

  • Question

  • When I run a full backup for a particular customer it creates the space file zip correctly in the customer's space folder. Then once it transfers the file to the hosting backup folder the file just seems to get larger and larger untill it fills up the whole disk space.

    This only happens to the one account and all the others seem fine.

    Does anyone know why this is happening?

    Thursday, April 21, 2011 2:01 AM

All replies

  • Further to my problem I tried creating a new account and transferred the sites over to the new account, 2 in total.

    I first transferred 1 site and ran a backup with success. Transferred the 2nd site and the backup failed. The backup file being created is over 2gbs.

    It seems like if the site is too large the backup fails.

    Here is the error from the website logs...

     

    [4/21/2011 10:41:06 PM] ERROR: 'Windows Server 2008' GetFileBinaryContent

    System.IO.IOException: The process cannot access the file 'C:\www\koch\SpaceFiles_37_634390208231200241.zip' because it is being used by another process.

       at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)

       at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy)

       at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy)

       at System.IO.FileStream..ctor(String path, FileMode mode)

       at WebsitePanel.Providers.Utils.FileUtils.GetFileBinaryChunk(String path, Int32 offset, Int32 length)

       at WebsitePanel.Providers.OS.Windows2003.GetFileBinaryChunk(String path, Int32 offset, Int32 length)

       at WebsitePanel.Server.OperatingSystem.GetFileBinaryChunk(String path, Int32 offset, Int32 length)

    Can anyone help me???

    Thursday, April 21, 2011 2:23 PM
  • Hi there,

    It seems that there is a bug in Backup module functionality when it tries to recover after an exception has been thrown during the backup procedure. Could you please advise if you are able to reproduce this scenario on a permanent basis?

    Anyway, I would really appreciate if you provide us with either steps to reproduce or access to the environment, so we could have a look into it.

    Thanks.


    Please vote, if you find a post helpful! Appreciate.
    Thursday, April 21, 2011 5:00 PM
  • Thanks for replying, yes I can, it happens all the time when you create a backup for this client. You can contact me on littlefigs@hotmail.com for access details
    Friday, April 22, 2011 1:59 AM
  • Hi I'm still having problems with this issue, could you please contact me on littlefigs@hotmail.com or replay for further details.

     

    Thanks,

    Monday, July 4, 2011 7:06 AM