locked
Issues with LinkButton on IIS 10 / Windows Server 2016 RRS feed

  • Question

  • User-1236840338 posted

    I have recently migrated my web application to a new Server using IIS 10, and Windows Server 2016. Once I migrated my app, the LinkButton controls stopped working. Image Buttons, and standard buttons, however, LinkButtons generally do not work. The LinkButtons that seem to have the most issues are ones that simply navigate to another web page. If you could provide any suggestions as to the issue, I would much appreciate. Thank you.

    Legacy version of .NET is 4.5, and this is a web application.

    NOTE: Code was working with no issues on legacy servers.

    NOTE: Control general control syntax <asp:LinkButton id="lnkLink" runat="server" />

    Tuesday, August 14, 2018 6:35 PM

All replies

  • User475983607 posted

    NOTE: Control general control syntax <asp:LinkButton id="lnkLink" runat="server" />

    There's no OnClick handler (or PostBackHandler).  As written clicking the link button will just post back.

    Tuesday, August 14, 2018 7:43 PM
  • User-1236840338 posted

    hi, thank you for the reply. The code I posted was generic code, not the actual code. There are OnClick, adn PostBackUrl properties for all my Linkbuttons.

    Tuesday, August 14, 2018 8:26 PM
  • User1724605321 posted

    Hi ericchadley ,

    Have you confirmed whether any javascript error occurs on your web page ?

    Best Regards,

    Nan Yu

    Wednesday, August 15, 2018 5:58 AM
  • User-1236840338 posted

    Nan - No, I have not done that yet, what would be the best way to see those?

    Wednesday, August 15, 2018 3:37 PM
  • User1120430333 posted

    Nan - No, I have not done that yet, what would be the best way to see those?

    F12-key  Developer Tool, which is on all major browsers. You should be able to use Bing or Google to find tutorials on how to use the tool for a given browser.

    Wednesday, August 15, 2018 8:32 PM