none
BizTalk EDI -- ISA5: Data element too shorT RRS feed

  • Question

  • I'm using the inbound is XML and outbound is EDI (270). Using BizTalk 2006 R2 developer edition, i am trying to achieve this part. But i'm having the below error.

    Error details: There was a failure executing the send pipeline: "Microsoft.BizTalk.Edi.DefaultPipelines.EdiSend, Microsoft.BizTalk.Edi.EdiPipelines, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" Source: "EDI assembler" Send Port: "XXXXSendPort" URI: "EDI://7654321:ZZ:7654321" Reason: X12 Message can not be serialized due to invalid party configuration for xxxx, 1st validation error has description ISA5: Data element too short.

    Please direct me if anyone knows how to fix this guy.

    Thanks,
    Raja

    Tuesday, July 7, 2009 11:44 AM

Answers

  • Hi,
        Is it resolving to the same party? Please see the context property of the message and find the party in that it should be the same party.

    For the context you can go to the suspended message and open the message details and then go to the context, see the party name there.
    It should be the same party name for that you configured ISA5, ISA6,ISA7, ISA8 and GS segment setting.


    Thanks
    Gyan
    If this answers your question, please mark it as "Answered".
    Wednesday, July 8, 2009 2:19 PM

All replies


  • Raja,
     
    This would normally mean that your ISA05 element is not of the correct length.  The ISA05 is the sender party code and must be 2 characters in size. In the ISA below, the ISA05 contains "ZZ".  Remember that the ISA segment is fixed length, so all the fields must be the correct lengths.

    ISA^00^          ^00^          ^ZZ^SENDER         ^ZZ^RECEIVER       ^090706^1930^U^00401^001970204^0^P^|~
     
    Jim

    Jim -- Pro Mapping in BizTalk 2009, Apress Books, March 23, 2009
    Tuesday, July 7, 2009 3:23 PM
  • Hi,
        In the party as a receiver setting you should give the ISA5, ISA6,ISA7, ISA8 and GS segment setting.

    Thanks
    Gyan
    If this answers your question, please mark it as "Answered".
    Wednesday, July 8, 2009 5:21 AM
  • I gave the values for ISA5, ISA6,ISA7, ISA8 and GS segment setting. But no luck. Is there any other sample link how to do converting the XML to 270 edi inbound. I don't know where i am doing mistake.

    Thanks,
    Raja


    Thanks, Raja
    Wednesday, July 8, 2009 11:53 AM
  • Hi,
        Is it resolving to the same party? Please see the context property of the message and find the party in that it should be the same party.

    For the context you can go to the suspended message and open the message details and then go to the context, see the party name there.
    It should be the same party name for that you configured ISA5, ISA6,ISA7, ISA8 and GS segment setting.


    Thanks
    Gyan
    If this answers your question, please mark it as "Answered".
    Wednesday, July 8, 2009 2:19 PM
  • Hi, RajaKumaravel

    Does Gyan's idea help you? We will mark Gyan's reply as answer, if you find anything new, please update here.

    Thanks
    Microsoft Online Community Support
    Tuesday, July 14, 2009 1:53 AM
    Moderator
  • Andrew,

    This problem still coming if i choose send port as edisend but it is working fine with xmltransmit.

    Thanks, Raja
    Tuesday, July 14, 2009 7:34 AM
  • Raja - Even though you are receiving the 270 Request Message, it is important to set a default GS Header for the 997 to be produced with EDISend Pipeline.

    So in your case, currently you have set the EDI 270 in the "Party as Interchange Sender" to receive the incoming 270.

    For the 997 to work, you will now setup "Party as Interchange Receiver" and configure the ISA Segment with the Party Sender/Receiver and Qualifier values. And also configure the “GS and ST Segment” to either a dummy EDI transaction (if you don’t have any outbound to this Partner).

    If you setup an actual Outbound transaction as outbound, that  will do the trick.

    Hope this ellaborate what has been said so far.

    -amit


    amit kumar
    • Proposed as answer by technoamit Wednesday, December 23, 2009 4:40 AM
    • Edited by technoamit Wednesday, December 23, 2009 4:40 AM spell check.
    Wednesday, December 23, 2009 4:29 AM