none
Why is the F7 toggle between code behind and source view nonfunctional in 2015 Enterprise?

    Question

  • A coworker wrangled it into working on Community, but there is nothing I can do to make it work in Enterprise, web forms *or* Windows forms. I can F7 from the designer/source to code behind, and then shift+F7 to the designer ONLY IF the designer is enabled. This ignores the default view setting, it always shows the designer regardless of being set to source, and source being the last mode it was in.

    This is absolutely intolerable.

    Monday, February 20, 2017 10:33 PM

All replies

  • Hi timeshifter,

    According to your description, I created a web forms project, and press F7 and Shift+F7. If a web form has been enabled, F7 will switch to background code, and Shift+F7 will switch Design and Source panel. I think there is nothing wrong with this feature.

    In your side, if has something wrong with this feature, please try to reset the VS:

    Tools->Import and Export Settings->Reset all settings->next->next->choose a options you want to reset.

    If I misunderstand your issue, please feel free to let me know.

    Sincerely,

    Oscar


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Tuesday, February 21, 2017 7:44 AM
    Moderator
  • >I think there is nothing wrong with this feature.

    I do, because it's a change that adds complexity where none needed to exist. Also, F7 CAN toggle between code-behind and source view in Community edition, BUT NOT ENTERPRISE. Whether *you* find it useful or not, it is a version difference that should be rectified.

    Tuesday, February 21, 2017 2:57 PM
  • Hi timeshifter,

    All my operations are based on enterprise version. So in my first reply, I suggest you could reset the VS to see whether has the same issue.

    In addition, please try the following step:

    Click Start->Developer Command Prompt for VS-> type “devenv.exe /ResetSettings

    Sincerely,

    Oscar


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, February 22, 2017 1:49 AM
    Moderator
  • Hi timeshifter,

    Whether you have changed the shortcuts in VS Enterprise? If yes, we could try to reset it via Tools->Options->Keyboard:

    Sincerely,

    Oscar


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Wednesday, February 22, 2017 8:23 AM
    Moderator