Cannot load ads in production version RRS feed

  • Question

  • I am trying to implement Microsoft's advertising SDK. I had it working quite well with both test ids and my Application/Unit ids. However after I uploaded the app to the store, I can no longer load ads when using my Application/Unit id. I always get the error 'NoAdAvailable'. Any ideas as to why this might be?


    Monday, October 14, 2019 2:58 PM

All replies

  • Hi John Gaby,
    There are many reasons you may see no ads, including network errors,app not receiving a lot of traffic for folks to bid it. How long did your Ad create?If you created a new ad unit ID in the past half-hour, you might not see an ad until the servers propagate new data through the system. Existing IDs that have shown ads before should show ads immediately. By the way, is your app a new app? Is it publish as private or public?

    Best regards

    Daisy  Tian

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact

    Tuesday, October 15, 2019 2:38 AM
  • The ad was created many days ago. The app was originally published as private, but I changed it to public thinking that might be the problem, but it made no difference. As I said the AppID/UnitID worked until I published the ad (although I believe that before publishing all I ever saw was test ads). Now the AppID/UnitID always returns 'NoAdAvailable'. I currently have the app unpublished, but I can publish it again and give you the link if you would like to investigate.


    Tuesday, October 15, 2019 2:13 PM
  • Several things you can look at

    i) go back to using test ads. if they are being displayed then the implementation is probably mostly correct

    ii) banner ads: check the ad sizes you are attempting to use. In general if banner ads are not 728x90 expect a 0% fill rate from live ads

    iii) if interstitials used, fill rates are frequently sub 10% + will depend on territory.

    iv) did you leave the live app published in App Store for about 48hrs. If not it can easily take 48hrs for live ads to become available.

    v) Before publishing you will ONLY ever see test ads.

    vi) Dont test your 'live' app on your development machine. Find a clean PC + download your app from store to see whether its displaying ads - non store downloaded app and/or development PC dont play ball that often.

    vii) Look at your Developer Dashboard, 'Ad performance', 'Filters', 'Aggregation' and see if your app is listed. If not contact MS support as this is a 'known' broken dashboard issue that MS seem to have to fix with a big stick.

    viii) Reporting is always WEEKS AND WEEKS AND WEEKS (30 days is the current record) BEHIND reality. Apparently its too difficult to obtain, add + display a few numbers. Our dash reporting still waiting for data from late Sept. The only thing you can do is wait a week or so to see if any impressions are being recorded. Not scientific, but....

    ix) Look at 'Monetize', 'In app ads'. If your 'ad unit name' is an ID instead of the text name you enterd see vii) above.

    Good luck!

    Thursday, October 17, 2019 2:27 PM
  • I have investigated this further. To address your points:

    i) It works with test ads, only ads using my AppId/UnitId do not work

    ii) I am using interstitial ads only

    iii) The problem is not that I am seeing a low fill rate, the ads are NEVER filled.

    iv) The app has been published for more than 48 hours

    v) The app is published

    vi) I have tested it on a non-development machine and I still get a zero fill rate.

    vii) The app is not shown on this page. How do I contact MS support?

    viii) It has not yet been that long, but the ads are NOT being filled

    ix) The ad name is the name I entered.

    At this point, I am at a loss of what to do next, so if I cannot get help from Microsoft in resolving this issues, I will be forced to abandon my attempt at getting this app into your store.  Pity.
    Saturday, October 19, 2019 5:08 PM
  • You can use the 'Support' open in your Developer account...

    Typically gets you to

    MS Suppport web page

    Choose 'Contact us'...

    Sunday, October 20, 2019 10:44 AM
  • I tried that but it appears that I have to pay a large sum of money to get any help from there.
    Tuesday, October 22, 2019 1:49 AM
  • MS offer FREE support for e.g. dashboard issues - from the link above....
    Tuesday, October 22, 2019 11:41 AM
  • I will give that a try, thanks.
    Tuesday, October 22, 2019 2:11 PM
  • I will give that a try, thanks.

    No luck right? It's MS problem with all new apps.

    Tuesday, November 5, 2019 4:39 AM