none
Windows Server 2012 Standard - HP OfficeJet Pro 8600 Plus printer not working after promoting to Domain Controller / AD Services RRS feed

  • Question

  • An associate and myself installed the built-in drivers for the HP OfficeJet Pro 8600 Plus multi-function (network) printer on a Windows Server 2012 Standard server installation and everything worked fine whenever I want to print anything directly from the Windows Server machine (there's a reason for this, so please understand that ;)  ).

    We were able to print without any problems from the Windows Server 2012 machine, using the drivers from Microsoft.  Mainly, because HP has not listed any specific support for Windows Server 2012, only Windows Server 2008 R2, however, the drivers that came with Windows 2012 seem to work very well.

    PROBLEM: I later had to promote the Windows Server 2012 to a Domain Controller, and created the Active Directory configurations, even enabled the Print Services.  After doing all of that, the HP printer will not print anything.  It's like all print requests directly from the Windows Server go to Nil.

    Has anyone encountered a problem like this before? The only thing I can think of is that after perhaps something affected printing directly once we promoted the server to being a DC, and added other features / roles.  I even tried installing the HP drivers for Windows Server 2008 R2, and the results are still the same...nothing prints.  Trust me, the printer is set as the Default Printer and even when choosing to print, we make sure the HP OfficeJet Pro is selected, and is on, as other Windows Client PC's can print to it directly.

    Does anyone have any suggestions we could try?  Thanks in advance.

    Thursday, December 5, 2013 3:36 AM

All replies

  • While it is quite a while since this was posted - I can concur a similar issue exists.

    We have spent the better part of a day trying to work out why other HP printers work fine but our 8620 prints are not printing and going to Nil.  The print server is hosted on a shared DC.  Comparing to the initial posters details, for some reason it seems to be most commonly related to the OfficeJet Pro 8600/8610/8620/8630 series printers.

    I ended up doing a print server migration from the domain controller to stand alone host and all printers now work from a single server rather than a mix.  Domain controller OSes varied from 2008, 2012, 2012 R2 (tested with multiple) and only after all of those failed then tried a stand alone server os machine as a last resort which worked fine.  Printing directly from Win 7 / 8 /8.1 clients to the IP always worked.

    Sunday, September 7, 2014 10:57 PM
  • The problem has to do with permission on the spool folder(C:\Windows\System32\spool). I don't know what they should be exactly but adding Everyone with Modify fixes the problem. 
    Friday, February 27, 2015 11:51 PM