none
Access 2016 web app 'After Update' not passing parameters from Form RRS feed

  • Question

  • I have a form1, and a couple of tables (table1 and table2)

    2 macros, one to lookup a field in table2 based on a parameter from form1, and this should all update to table1

    My issue, the 'lookup record' macro is working fine.. however

    the 'After Update' trigger does not grab the data from the Autocomplete text box and store in the passing parameter.

    to Debug, I ran the macro trace.. and when I 'hard code' the value of the Autocomplete field to the 'After Update' parameter, this works fine, and the correct fields are retrieved from table2 and stored in table1. but changing to take the value of the Autocomplete field on the form1, this does not work.

    this is the details of what does not work.

    any ideas....

    Thursday, September 1, 2016 5:32 PM

Answers

  • Hi jph,

    >> but changing to take the value of the Autocomplete field on the form1, this does not work

    Could you share us how you bind Autocomplete field? I suggest you check the value of AutoComplete field by MessageBox in “After Update” event. In AucoComplete control, if Bound Field and Primary Display are the same, you could use AucoComplete Control name directly to get value of AucoComplete control. If they are different, you will get Bound Field value and you need to get the Display name by Bound Field value.

    Best Regards,

    Edward


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Friday, September 2, 2016 9:15 AM