none
Update service reference in vs2010 RRS feed

  • Question

  •  

    I have one project developed using vs2005. After upgraded vs2005 to vs2010 and changed target framwork to 4.0, I still cannot see 'update service reference' menu.

    Please help!

    Thanks

    Tuesday, June 5, 2012 8:54 PM

Answers

  • Hi VS2010_new,

    Welcome to the MSDN forum.

    Do you mean that when you right click the service reference and then you can not find Update service reference button?

    Have you tried to Add and Update the service with this instruction http://msdn.microsoft.com/en-us/library/cc668183

    Also, could you please build a new fresh project to see if you can add a service reference and update it.

    Seems that this option was embeded on Visual Studio.

    Please try these first and if no help ,try devenv.exe /resetsettings to see if this command can help.(It can be ran on"Start>>Run command")

    If you have any updates, please feel free to let me know.

    Thanks,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    • Marked as answer by VS2010_new Thursday, June 7, 2012 4:32 PM
    Thursday, June 7, 2012 5:38 AM
    Moderator

All replies

  • As I understand it, you have a Visual Studio issue, not a .NET Framework issue. Please correct me if I misunderstood.

    For best answers to Visual Studio setup questions, please ask here:

    http://social.msdn.microsoft.com/Forums/en-US/vssetup/threads

    Tuesday, June 5, 2012 9:54 PM
  • I think you are right. VS2005 has WCF extension. If install this, the "update service reference" menu will show up. I cannot find the similar extension in vs2010. I don't know how to get it back.

    Any idea? Thanks.

    Wednesday, June 6, 2012 3:21 PM
  • Hi VS2010_new,

    Welcome to the MSDN forum.

    Do you mean that when you right click the service reference and then you can not find Update service reference button?

    Have you tried to Add and Update the service with this instruction http://msdn.microsoft.com/en-us/library/cc668183

    Also, could you please build a new fresh project to see if you can add a service reference and update it.

    Seems that this option was embeded on Visual Studio.

    Please try these first and if no help ,try devenv.exe /resetsettings to see if this command can help.(It can be ran on"Start>>Run command")

    If you have any updates, please feel free to let me know.

    Thanks,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    • Marked as answer by VS2010_new Thursday, June 7, 2012 4:32 PM
    Thursday, June 7, 2012 5:38 AM
    Moderator
  • Hi Barry,

    I found way to fix it. Thank you.

    • Marked as answer by VS2010_new Friday, June 8, 2012 3:14 PM
    • Unmarked as answer by VS2010_new Friday, June 8, 2012 3:15 PM
    Thursday, June 7, 2012 4:29 PM