none
A solution for the "user-mapped section open" error RRS feed

  • Question

  • Did anyone ever identify the cause of the "user-mapped section open" error that Expression Web gives when trying to save a file?  It has followed me through two versions of EW and two computers.  For a while on the new computer, I didn't get the message so I thought it was something system related to the old computer.  Then it started happening again.

    As I think back, there was a time on the new computer that I didn't have Carbonite reactivated yet.  I'll have to try turning it off and see if the problem goes away.  I stumbled across this topic on this forum while Googling for a solution.

    Thanks for any updates.

    Jean Painter

    Tuesday, July 3, 2012 9:18 AM

All replies

  • This isn't a problem with Expression Web. As others have noted in the very few other threads on the topic, the problem is caused by another program trying to control access to the file(s). They won't relinquish control. Likely culprits are automatic backup programs like Carbonite or Mozy, or anti-virus programs. The problem is a system-level one and Expression Web is the victim, not the cause. Read those other threads and try what they suggest, but this is not something caused by Expression Web.

    A call to action:
    What do we want?!
    Time travel!
    When do we want it?!
    That's irrelevant!

    • Proposed as answer by Paul Zahorecz Tuesday, July 3, 2012 1:32 PM
    Tuesday, July 3, 2012 11:41 AM
  • The error says another process has an open file handle for the file.  it's up to you to figure out what you are running that would be doing that. It's not an EW error, and probably doesn't have just one cause.
    Tuesday, July 3, 2012 11:50 AM
  • It's great to understand that.  I did pause Carbonite while I worked on EW for a little while this morning and that seems to have solved the problem.  After a longer trial, I will report back with long term results.  Hopefully someone else will benefit too.
    Tuesday, July 3, 2012 2:59 PM
  • Now that enough time has elapsed, it appears that by freezing Carbonite when I use EW most of the problem disappears.  If  it still happens on occassion, if I pause Microsoft's Security Essentials (virus protection)  real time protection, that completely stops the error.  Not a great solution but at least a work-around. 

    I hope this helps someone else.

    jpainter

    Friday, August 10, 2012 7:28 AM