Kinect for Windows V2 periodically disconnects on Windows 10 1809. RRS feed

  • General discussion

  • It disconnects and then reconnects every few seconds.

    I have tried everything discussed in the forum and I have also completely uninstalled and reinstalled SDK and driver, nothing helped.

    Wednesday, October 3, 2018 2:19 AM

All replies

  • I have the exact same issue,  JUST started after having Windows 10 v1809 installed from fresh install.
    Wednesday, October 3, 2018 8:53 PM
  • Same problem here after 1809 upgrade !
    Thursday, October 4, 2018 12:22 PM
  • Here this happens too, after updating to 1809 kinect goes on and off periodicaly

    that's really annoying .... 

    Thursday, October 4, 2018 12:50 PM
  • Is this when you simply connect the Kinect or when testing it in Kinect verifier?

    Also check in the task manager if KinectService.exe is stable, no matter if Kinect is connected.

    [edit] Here is a rare instance of a Microsoft Engineer taking note of an Kinect V2 issue:

    • Edited by Yanis Lukes Thursday, October 4, 2018 5:23 PM Rare Samaritan
    Thursday, October 4, 2018 3:17 PM
  • It happens when I simply connect the Kinect.

    KinectVerifier shows the same thing shown in the devices setting i.e. Kinect is connecting and disconnecting every few seconds.

    KinectService starts and stops also when Kinect is not connected, it could be the cause of this issue.

    • Edited by Scasc Thursday, October 4, 2018 9:05 PM
    Thursday, October 4, 2018 9:00 PM
  • Hi everyone -

    I'm an engineer at Microsoft working on Kinect for Windows.  We are working on a solution for this.  Some additional information that might be useful if you're encountering this:

    -   This problem started occurring on Windows 10 1809 and results in KinectService.exe restarting constantly.

    -   The issue is intermittent and on some PCs does not occur on all boots.  Rebooting may temporarily resolve it.

    When I have more information to share I'll post it to this forum.


    Friday, October 5, 2018 2:04 AM
  • KinectService starts and stops also when Kinect is not connected, it could be the cause of this issue.

    Aha, so I take it KinectService.exe is restarting even if you hadn't connected Kinect on boot at all. That means my problem has become an issue even for other USB controllers.

    If it is so, @brythi see my MSDN thread for more extensive info.

    Friday, October 5, 2018 12:56 PM
  • The same happens to me. If I uninstall "Kinect runtime dev" the issue stops, the system can detect the Kinect under "devices" (the drivers are still installed) but the Kinect does not work ("unable to detect sensor" if I run 3d scan).

    I'm not a dev, just want to use Kinect as a 3d scanner. Is there a Kinect runtime version without the issue, that can be used in windows 1809?

    Saturday, October 6, 2018 8:31 AM
  • Is there a Kinect runtime version without the issue, that can be used in windows 1809?

    Yes... Kinect Runtime non-Dev. But since you uninstalled Runtime Dev, then it also deletes the whole Kinect Service. So you also have to uninstall Kinect Runtime and re-install it. However, Windows may decide to still automatically install Runtime Dev. It is strange, as I state in my thread, the app first appeared when you added the DriverFlighting key, but now it is automatic.
    Saturday, October 6, 2018 10:50 AM
  • Some additional information that may help,

    Funny enough, on slow insider ring, the latest preview right before this update had the drivers working.

    Two preview versions back had the same service problem as the final release.

    May be something to look into and replicate with your internal Windows builds. Perhaps your team can pinpoint the differences if you can replicate the behavior I experienced.

    P.S. Intel 8700k with Intel USB 3.1 onboard chipset

    • Edited by Shad0wLAGX Saturday, October 6, 2018 8:09 PM
    Saturday, October 6, 2018 8:02 PM
  • i also have this problem reinstalled all from scratch but it does not work i tried whit another laptop hp x2 and not work. two pc with build 1809. Whith build 1803 everything was ok

    • Edited by matteo19810 Monday, October 8, 2018 7:50 PM
    Monday, October 8, 2018 7:49 PM
  • How soon will this fix be available? Working on a project with Kinect and it is on hold because of this.
    Tuesday, October 9, 2018 9:24 AM
  • @teejosh, as I stated in my previous reply. See if uninstalling Runtime Dev & Runtime through Settings -> Apps, and installing plain Runtime again, and then rebooting helps.

    • Edited by Yanis Lukes Tuesday, October 9, 2018 12:37 PM reboot
    Tuesday, October 9, 2018 12:32 PM
  • I am in the same boat! Not great as people rely on the device to make money! 
    Tuesday, October 9, 2018 2:03 PM
  • With just Kinect runtime (no runtime_dev) the Kinect does not disconnect and reconnect repeatedly and it is seen by the system, but it does not work (if I run 3d scan it crashes, if I try to use Kinect with skype it freezes). It is strange since Kinect runtime installed both runtime and runtime_dev, then I uninstalled only runtime_dev and rebooted, but with just runtime (non _dev) installed it does not work. Is there any kind of solution?

    • Edited by Andrea Lioce Wednesday, October 10, 2018 2:19 PM
    Wednesday, October 10, 2018 2:19 PM
  • With today's window 10 update, after uninstalling -> rebooting -> reinstalling -> rebooting Kinect runtime, the Kinect works again. I don't know if it's a stable solution or just a case, but it works again.
    Wednesday, October 10, 2018 2:51 PM
  • I also have this issue with update 1809 - kinectservice.exe shuts down every 5 seconds. Talking with support I came to the conclusion that Kinect's just broken. But after seeing your thread I started hoping again. So, yeah, thank you!

    I've found this reddit thread on the issue but it's not really helpful.

    Apps that try to use it come with either "Some other App is using Camera right now" or "Cannot detect your camera".

    Kinect configuration verifier from SDK seems to shutdown when trying to get frames from image sensor. Mic's working alright though when kinectservice.exe is online.

    Weird thing that it was not instant and first few runs on 1809 were just fine. It's the day after the update Kinect stopped working.

    Wednesday, October 10, 2018 4:35 PM
  • I had the same problem with update 1803. The update of the C++ Redist. Packages has fixed it. Now it is working.

    • Edited by DeNydcht Thursday, October 11, 2018 8:53 PM
    Thursday, October 11, 2018 8:48 PM
  • What version does your Windows 10 report? I'm not clear what "today's windows 10 update" is. My system updated on the 9th, with KB4464330 and is now reporting a build of 17763.55. I still am unable to stop the connect/disconnect. 

    For anyone else trying this, it wasn't apparent to me, but you uninstall the runtime by running it on the command line with /uninstall.  Ok weird, it wasn't in my apps and features list before, but now it is. I think I might have had 2 versions in SBS. I wonder if that was the issue.

    I'm about to try the reboot/reinstall/reboot cycle and see if it works for me now. I'll try the C++ redist later if that doesn't do it.

    Friday, October 12, 2018 12:49 AM
  • I had the same problem with update 1803. The update of the C++ Redist. Packages has fixed it. Now it is working.

    Which C++ redist? I imagine most people have multiple versions, I certainly do.

    Friday, October 12, 2018 12:50 AM
  • @MasterChiefmas, I have started the normal windows update and it updated all installed versions of C++ redist... starting from c++ redist 2005...
    • Edited by DeNydcht Friday, October 12, 2018 6:46 AM
    Friday, October 12, 2018 6:45 AM
  • As a temp fix you could try to insert something else into the usb port. Reboot alone didn't work for me. I inserted an external drive in the USB port where Kinect had been, then safely removed it. Next when inserting Kinect it worked. That seemed to break some hang up error.

    Not only did it disconnect back and forth, after a while it wasn't even recognized. This error showed up now after long time of flawless function, however had similar error a few years ago.

    Saturday, October 13, 2018 11:10 PM
  • With today's window 10 update, after uninstalling -> rebooting -> reinstalling -> rebooting Kinect runtime, the Kinect works again. I don't know if it's a stable solution or just a case, but it works again.

    Only temporary fix, with today boot the issue is still present. My C++ redist is updated but the problem is still here. 
    Monday, October 15, 2018 11:17 AM
  • Hi Bryan,

    Since it's already been about 2 weeks, what is the anticipated timeline for the fix? Should we all revert back to 1803?


    Wednesday, October 17, 2018 3:25 PM
  • Same problem here please fix!
    Sunday, October 28, 2018 3:46 PM
  • I've been having this issue as well. Interestingly enough, I have found that whenever I update the driver for my AMD RX 480, it sometimes causes the Kinect to "restabilize" if it was doing its disconnect cycle or destabilize if it was going through a period of actually working.

    Note that I have an NVidia GTX 1080, AMD RX 480, and Intel HD graphics all working in tandem on the same PC (IGFX is GPU 0, GTX 1080 is GPU 1 with my primary monitor on it, RX 480 is GPU 2), but it's only when I update the AMD driver that something happens to the Kinect. In fact, according to the NVidia GPU activity monitor, KinectService.exe is not even running on my primary GPU--it appears to be latching onto the RX 480 instead, which is odd. Doubly so considering I have tried setting KinectService.exe to use the NVidia card in Windows 10 graphics settings and the NVidia control panel, apparently to no avail.

    EDIT: The system is currently on Windows 10 17763.107.
    • Edited by KNNSpeed Wednesday, October 31, 2018 4:17 PM
    Wednesday, October 31, 2018 4:11 PM
  • I fixed this by enabling kinects mic in windows sounds panel, it had somehow gotten disabled.
    Saturday, November 3, 2018 4:54 PM
  • I read what KNNspeed wrote. So I decided to try an installation of an old driver (391.01) for my Nvidia GT710 instead the last one (416.34) . I did a "new installation" . And ... my Kinectv2 worked normally on my win10 1809 64-bit . I tested all my apps I use normally and everything worked ok again. Hope this helps some (or all of you)  guys.

    Sunday, November 4, 2018 2:23 PM
  • The problem is back again. I wanted to test something today . And the kinect device is flickering again in the device manager windows. F*** 1809, because I have a lot of other issues with that release. MS did a bad job.
    Monday, November 5, 2018 1:11 PM
  • Still not fixed. I'll have to sell my Kinect, bought only to use with Microsoft 3D Scan. If this is not supported anymore just tell us, and remove 3D Scan from windows store. That's a shame!
    Thursday, November 8, 2018 4:13 PM
  • Hi Bryan,

    any update on the bug with Kinect and Windows 10 update 1809 ?

    Any good fix ?

    Please answer. It's been long enough (october 5th) since your last comment on this thread.

    thank you

    Wednesday, November 14, 2018 5:57 PM
  • We have a new release of the Kinect for Windows Runtime that should address the issues being described here.  Please see this thread for details:


    Wednesday, November 14, 2018 10:36 PM
  • Works fine for me. The driver have been automaticaly updated today et I can set Windows Hello without problem.
    Thursday, November 15, 2018 6:18 AM
  • Yes it works!
    Tuesday, November 20, 2018 11:21 AM
  • I'm having issues with Kinect constantly restarting when I try to use it as well.  Initially, it was just working intermittently after upgrading Windows 10 1809. It wasn't that big of an issue at first. I had to contact Microsoft support (3rd party white branded ignorant wannabe techs) where their only solution to every problem is to create a new user so you have to customize everything again and get it set up the way you want everything again or do a fresh install of windows where I have waste 3 days installing all my software due to my slow DSL, Updates, install games, and fix home network sharing bugs that havn't been resolved since Windows 10 was released but weren't present during the technical preview. So after working (wasting my time with the sad excuse of support techs Microsoft hires) with Microsoft support and having the tech make changes I didn't want or approve by time I could attempt to say anything after fighting for control of my computer to respond he typed in a command to restart my system where I had to contact them again just to start over from scratch and any attempt to speak to a supervisor was refused and a bigger waste of time. Go figure right, but that's my consistent experience with Microsoft "support" so Anyways I ended up deciding it would be saving time to just reinstall my operating system, all my software, drivers, customizations, updates etc. and three days later since that's actually saving time compared to dealing with wannabe Microsoft tech support Now my Kinect won't work at all. It's constantly restarting, I can't use the Windows Hello facial recognition log in any longer, When I try to use the camera on the Kinect I get a (We can't find your camera, check to be sure it's connected and installed properly, that it isn't being blocked by antivirus software, and that your camera drivers are up to date. If you need it here's the error code: 0xA00F4244<NoCamerasAreAttached>) and when I check Device Manager I see (This device cannot start. (Code 10)
    Current device power state cannot support this request.) under the current status. I try to right click on WDF Kinect Sensor Interface0 and update driver. go through that process and it downloads the drivers but during setup, I get an error saying it can't detect the camera to complete installation of drivers. I'd contact support but even though I just did a completely fresh install of the OS using the latest available windows media creator, wiped my drive and installed Windows 10 on a bare drive. That's all I'll get is a claim that it'll fix the issue or I'll end up getting false promises of their intentions and abilities while they put me on hold and put me back in the queue if I call or if I use the chat option they'll ask to remotely access my system restart it without notification so they'll get to get rid of me instead of doing their job or claim I'm required to pay for Microsoft to fix issues they've caused with releasing updates prior to working out all the bugs. I figured I'd try this as an option to resolve this issue. The best option I can think of is if their is a link to download drivers or another way I can install the drivers manually with camera unplugged or something that will allow the updated drivers to install completely without being required to detect the camera first. I have verified the camera works by connecting it to the Xbox One and another computer that is still running Windows 10 1709. So I know the Kinect and the powersource is working correctly. 

    • Edited by SHoover80 Friday, March 8, 2019 8:29 AM
    Friday, March 8, 2019 8:05 AM
  • I guess no response, Go figure. another issue with Windows left unsolved. Everyone's working on the next issues to cause and features that don't work. 
    Monday, March 18, 2019 4:53 AM
  • I'm having the same issues, it seems. :(
    Sunday, May 5, 2019 4:34 AM
  • I had the same issue.  Video would work for a few seconds then freeze.  The kinect microphone was disabled. Re-enabling fixed.

    Running the Kinect Studio v2.0 I could see that it was periodic and re-established itself; other apps may not do the same.

    Issue: I had disabled the kinect-mic array sensor in the sound control panel in "Manage Sound Devices".  "Microphone Array" Xbox NUI Sensor

    Solution: Re-enabling the kinect mic array that allowed the video stream to continue uninterrupted.  After re-enabling I uninstalled the kinect device; re-installed 

    Windows version: 1903 (Version 10.0.18362.295) 

    Kinect Driver version: 2.2.1811.10000

    Tuesday, August 27, 2019 3:49 PM
  • Yes, Now I remember having the same issue. Just enable the mic in audio control panel and it works well.
    Wednesday, November 6, 2019 8:38 PM
  • It looks like that the solution for using the "Xbox One Kinect Sensor" on Windows 10 is:

    1. For a stable connection use it with a USB-Chips-Set from Intel or Renesas
    2. Use the correct and latest drivers for your USB-Ports/Chipsets/Mainboard etc.
    3. Install the latest Windows 10 Updates (1809/1909)
    4. But most important are the Windows 10 Privacy-Settings: Enable "Allow access to the microphone on this device" AND "Allow apps to access your microphone"

    It's really annoying if someone needs to disable those privacy settings to keep his sensor working, but this should solve the problem with periodically disconnecting Kinect-devices on your computer.

    Dear Microsoft-Developers: Please update those drivers accordingly and bring back privacy!

    EDIT: Tested with 1809 and 1909.
    Saturday, December 21, 2019 3:44 PM
  • From what I understand the problem is bigger. The audio stream is part of the work that the SDK does every frame. It's a design issue. Every frame, the SDK performs processing for ALL streams. And there wasn't any functionality included that can disable streams in processing. Probably can't be removed, at least for the v2 SDK.
    Saturday, December 21, 2019 4:24 PM
  • This worked for me. I tried uninstalling a bunch of things, and this was a fresh install of the kinect drivers/runtime devices.

    Once I enabled the mic, it worked like a champ. Thank you.

    Control Panel -> All Control Panel Items -> Sound -> Recording -> Microphone Array -> Right-Click -> Enable

    Started up openTrack and the device stopped failing after ~8 seconds.

    Thank you

    • Edited by boaty2020 Sunday, May 17, 2020 4:21 AM
    Sunday, May 17, 2020 4:21 AM
  • I was using Kinect through Windows Remote desktop and it disconnected like this.

    But after doing it in front of the pc, it just worked.

    hope it help somebody

    Friday, June 26, 2020 10:37 AM