locked
Metadata contains a reference that cannot be resolved: 'http://localhost:12050/wcfDataManager RRS feed

  • Question

  • Could not connect to http://localhost:12050/wcfDataManager. TCP error code 10061: No connection could be made because the target machine actively refused it
     127.0.0.1:12050.

    Here is my app.config

    <?xml version="1.0"?>
    <configuration>
      <configSections>
        <sectionGroup name="applicationSettings" type="System.Configuration.ApplicationSettingsGroup, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" >
          <section name="ABC.CBOSYS.BofAICLSend.BofAICLSendService.My.MySettings" type="System.Configuration.ClientSettingsSection, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
        </sectionGroup>
      </configSections>
     <system.serviceModel>
      <behaviors>
       <serviceBehaviors>
        <behavior name="BofAICLSendService.wcfDataManager">
         <serviceMetadata httpGetEnabled="true" httpGetUrl="http://localhost:12050/wcfDataManager" />
         <serviceDebug includeExceptionDetailInFaults="true" />
         <serviceThrottling maxConcurrentCalls="100" maxConcurrentSessions="10"
          maxConcurrentInstances="26" />
        </behavior>
       </serviceBehaviors>
      </behaviors>
      <services>
       <service behaviorConfiguration="BofAICLSendService.wcfDataManager"
        name="ABC.CBOSYS.BofAICLSendService.wcfDataManager">
        <endpoint address="mex" binding="mexTcpBinding" contract="IMetadataExchange" />
        <endpoint address="" binding="netTcpContextBinding" bindingConfiguration="DuplexContextBinding"
         name="DataManagerBinding" contract="ABC.CBOSYS.BofAICLSendService.IwcfDataManager">
         <identity>
          <dns value="localhost" />
         </identity>
        </endpoint>
       </service>
      </services>
      <bindings>
       <netTcpBinding>
        <binding name="DuplexBinding" openTimeout="00:10:00" sendTimeout="00:10:00"
          maxBufferPoolSize="524288" maxBufferSize="524288" maxConnections="10"
          maxReceivedMessageSize="524288">
         <readerQuotas maxDepth="524288" maxStringContentLength="524288"
           maxArrayLength="524288" maxBytesPerRead="524288" maxNameTableCharCount="524288" />
         <reliableSession enabled="true" />
         <security mode="Message">
          <transport clientCredentialType="Windows" />
         </security>
        </binding>
       </netTcpBinding>
       <netTcpContextBinding>
        <binding name="DuplexContextBinding" maxReceivedMessageSize="524288">
         <readerQuotas maxDepth="524288" maxStringContentLength="524288"
           maxArrayLength="524288" maxBytesPerRead="524288" maxNameTableCharCount="524288" />
         <reliableSession enabled="true" />
         <security mode="Message">
          <transport clientCredentialType="Windows" />
         </security>
        </binding>
       </netTcpContextBinding>
      </bindings>
     </system.serviceModel>
    </configuration>
    
    

     


    *** Please allow me to mark threads as answered and I will, Thank you ***
    Monday, March 28, 2011 2:02 PM

Answers

  • Found the problem.  The Root namespace did not match the namespace in the app.config.
    *** Please allow me to mark threads as answered and I will, Thank you ***
    • Marked as answer by ski_freak Tuesday, March 29, 2011 4:59 PM
    Tuesday, March 29, 2011 4:59 PM

All replies

  • can you try to add base address under service as below

    <host>

              <baseAddresses>

                <add baseAddress="net.tcp://localhost:9000" />

              </baseAddresses>

            </host>

     


    -Vital
    Monday, March 28, 2011 2:40 PM
  • I added the following and still get the same error

    <services>
       <service behaviorConfiguration="BofAICLSendService.wcfDataManager"
        name="ABC.CBOSYS.BofAICLSendService.wcfDataManager">
        <endpoint address="mex" binding="mexTcpBinding" contract="IMetadataExchange" />
        <endpoint address="" binding="netTcpContextBinding" bindingConfiguration="DuplexContextBinding"
         name="DataManagerBinding" contract="ABC.CBOSYS.BofAICLSendService.IwcfDataManager">
         <identity>
          <dns value="localhost" />
         </identity>
        </endpoint>
        <host>
         <baseAddresses>
          <add baseAddress="net.tcp://localhost:9000" />
         </baseAddresses>
        </host>
       </service>
      </services>
    

    *** Please allow me to mark threads as answered and I will, Thank you ***
    Monday, March 28, 2011 2:44 PM
  • I have tried on my machine with your settings.Its is working fine for me(hostd in console app)

    make sure the port you are communicating to is not blocked by firewall


    -Vital
    Monday, March 28, 2011 4:30 PM
  • How do I find that out?  I am new to all of this WCF.
    *** Please allow me to mark threads as answered and I will, Thank you ***
    Monday, March 28, 2011 4:54 PM
  • Just found out we have no firewall blocking.
    *** Please allow me to mark threads as answered and I will, Thank you ***
    Monday, March 28, 2011 5:44 PM
  • I take that back, the win 7 firewall is on but no log.
    *** Please allow me to mark threads as answered and I will, Thank you ***
    Monday, March 28, 2011 6:28 PM
  • Hello, you're using NetTcpBinding, so you should use net.tcp rather than http.
    Lante, shanaolanxing This posting is provided "AS IS" with no warranties, and confers no rights.
    Windows Azure Technical Forum Support Team Blog
    Tuesday, March 29, 2011 3:11 AM
  • <behaviors>
          <serviceBehaviors>
            <behavior name="ABC.CBOSYS.BofAICLSendService.wcfDataManagerBehavior">
              <serviceMetadata httpGetEnabled="true" httpGetUrl="net.tcp://localhost:10021/wcfDataManager" />
              <serviceDebug includeExceptionDetailInFaults="true" />
              <serviceThrottling maxConcurrentCalls="100" />
            </behavior>
          </serviceBehaviors>
        </behaviors>
    Is that where you meant?  If so, I still get the same error.
    *** Please allow me to mark threads as answered and I will, Thank you ***
    Tuesday, March 29, 2011 11:06 AM
  • Found the problem.  The Root namespace did not match the namespace in the app.config.
    *** Please allow me to mark threads as answered and I will, Thank you ***
    • Marked as answer by ski_freak Tuesday, March 29, 2011 4:59 PM
    Tuesday, March 29, 2011 4:59 PM