locked
Elmah Does not Email RRS feed

  • Question

  • User794407132 posted

    Hi All, Good day!

    I just want to ask what should be the correct elmah.dll to be referred from my application?
    My application runs on IIS and I'm using Visual Studio 2008 - 3.5 framework running in 32bit.

    I've already added the elmah.dll and also set the configuration needed on the web.config but when I try to pull a test error, it doesn't send me an email.
    I'm using gmail as my host.

    Thanks in advance for the help.

    Thursday, January 28, 2016 9:59 AM

Answers

  • User-718146471 posted

    Can you review this posting by Scott Mitchell regarding ELMAH erroring on Gmail? http://scottonwriting.net/sowblog/archive/2009/05/21/163350.aspx

    The meat of the post I think you need to check is to ensure you are using SSL with GMail's smtp servers. First part of this is the web.config file:

    <elmah>
        <errorMail from="..." to="..." subject="..." async="true" />
    </elmah>
    
    <system.net>
         <mailSettings>
             <smtp deliveryMethod="network">
                 <network host="..." port="..." userName="..." password="..." useSsl="true" />
             </stmp>
         </mailSettings>
    </system.net>
    
    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, January 28, 2016 2:41 PM

All replies

  • User-718146471 posted

    Can you review this posting by Scott Mitchell regarding ELMAH erroring on Gmail? http://scottonwriting.net/sowblog/archive/2009/05/21/163350.aspx

    The meat of the post I think you need to check is to ensure you are using SSL with GMail's smtp servers. First part of this is the web.config file:

    <elmah>
        <errorMail from="..." to="..." subject="..." async="true" />
    </elmah>
    
    <system.net>
         <mailSettings>
             <smtp deliveryMethod="network">
                 <network host="..." port="..." userName="..." password="..." useSsl="true" />
             </stmp>
         </mailSettings>
    </system.net>
    
    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, January 28, 2016 2:41 PM
  • User794407132 posted

    Thanks for the blog and clean configuration setting.

    Monday, February 1, 2016 2:46 AM