locked
Bug calendar (Google) and time RRS feed

  • Question

  • Registered on the calendar of the Windows phone entries are shifted by one hour less.
    Out in gmail, the event is at the right time.

    Sorry if the translation is not great. I'm French and not writing too much English.

    Thursday, October 24, 2013 9:15 PM

All replies

  • kaartman -

    Thank you for posting!

    When I've seen an issue like this in the past, it's been caused by the time zone on the accounts being set to different countries.  I don't have a link I can give on where to check that setting for your Gmail account, but you can find the time zone for your Microsoft Account here:

    https://account.live.com/EditProf.aspx

    After making changes, on your phone go to Settings -> Email+Accounts and tap and hold on your Gmail account and select sync, and then do the same thing with your Microsoft Account, and see if everything lines up now for the times on everything.

    Let us know if you continue to have problems!

    Regards,
    Kevin J S

    • Proposed as answer by melocoosm Friday, October 25, 2013 6:03 PM
    Friday, October 25, 2013 6:06 AM
    Moderator
  • I'm also on GMT+1 and experiencing the same problems.

    When adding a new event in my Google Calendar on my Windows Phone it jumps one hour back in time shortly after adding it. When adding an event using https://www.google.com/calendar/ the hour settings gets synchronized correctly to my phone. This makes me suspect there's a glitch on the "upload" functionality when adding events to Google Calendar on a Windows Phone, either on Microsoft's or Google's side.

    I'm using a Nokia Lumia 920 with the latest updates.

    I've checked the time zone setting on both my phone, my live.com id and my google account, and they're all at GMT+1.

    This started happening quite recently, I believe after we changed from summer time back to regular time.

    Others are also reporting the same problem: http://productforums.google.com/forum/?nomobile=true#!topic/google-education/ZDqRvvjxsBI, http://windowsphone.stackexchange.com/questions/2582/sync-with-google-calendar-changes-time-of-new-items

    The observation of Michel van der Vleut in the Google Forum post is interesting:
    "[..] I configured 2 google accounts on the phone. When I schedule an event on the first account calendar, then it works fine.  When I schedule an event on second google account calendar, then the event is scheduled 1 hour back."

    I guess the workaround for now is to add all appointments one hour later than they occur, but it feels sort of stupid.
    Tuesday, November 26, 2013 8:10 PM
  • I had the same problem and it took me some time to fix it. Google calendar settings and windows phone settings were all correctly at gmt+1.

    I did the following: I set my windows phone time back to September 2013 (summer time) added a calendar entry and everything went well with the calendar. I set the time back to December 2013 (regular time) and then the calendar worked perfectly.

    I believe that the problem occurred when I had to set my date new after a reset. If you set the date before the time zone to a date with regular time, there is something wrong internally. Microsoft might want to check that. Its just a guess but the workaround should work (at least it was the way how I got rid of the problem).

    Sunday, December 8, 2013 11:20 PM