none
.NET 3.5 SP1 Beta setup fails on Vista SP1 RRS feed

  • Question

  • During install of the .NET 3.5 SP1 beta I get an error after it tries to download something which doesn't seem to work.

     

    In the file dd_dotnetfx35error.txt I find:

     

    [05/13/08,21:01:04] Microsoft .NET Framework 2.0SP1 (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 2.0SP1 (CBS). MSI returned error code 5
    [05/13/08,21:01:04] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0SP1 (CBS) is not installed.

     

    In the file dd_dotnetfx35install.txt I find:

     

    [05/13/08,20:53:03] Microsoft .NET Framework 2.0SP1 (CBS): "C:\Windows\system32\WUSA.exe" "f:\4418d91cc8c53848fc86279bcc\wcu\dotNetFramework\dotnetmsp\x86\NetFX2.0-KB948609-v6001-x86.msu" /quiet /norestart
    [05/13/08,20:53:03] Microsoft .NET Framework 2.0SP1 (CBS): CBSComponent Action: CreateProcess launched with cmd line : C:\Windows\system32\WUSA.exe "C:\Windows\system32\WUSA.exe" "f:\4418d91cc8c53848fc86279bcc\wcu\dotNetFramework\dotnetmsp\x86\NetFX2.0-KB948609-v6001-x86.msu" /quiet /norestart
    [05/13/08,20:53:03] BWaitForMSI(): Verifying we're the only installation currently in progress.
    [05/13/08,20:53:03] BWaitForMSI(): Ready to proceed with installation.  Continuing...
    [05/13/08,20:53:03] Microsoft .NET Framework 2.0SP1 (CBS): C:\Windows\system32\WUSA.exe exited with return value 5
    [05/13/08,20:53:03] InstallReturnValue: GFN_MID NET Framework 2.0SP1 (CBS), 0x5
    [05/13/08,20:53:03] Setup.exe: AddGlobalCustomProperty
    [05/13/08,20:53:03] Setup.exe: AddGlobalCustomProperty
    [05/13/08,20:53:03] Microsoft .NET Framework 2.0SP1 (CBS): ***ERRORLOG EVENT*** : Error: Installation failed for component Microsoft .NET Framework 2.0SP1 (CBS). MSI returned error code 5

     

    When I extract the dotnetfx35.exe file manually and try to start any of the msu files in wcu\dotNetFramework\dotNetMSP\x86\ I get the message (translated):

     

    The setup program reported an error: 0x80070005

    Access denied

     

     

    In the event log the following shows up:

     

    Das Windows-Update konnte aufgrund eines Fehlers nicht installiert werden: 2147942405 "Zugriff verweigert" (Befehlszeile: ""C:\Windows\system32\WUSA.exe" "f:\da91add8297ef1ffc885a0\wcu\dotNetFramework\dotnetmsp\x86\NetFX2.0-KB948609-v6001-x86.msu" /quiet /norestart")

     

    Translation:

    The Windows Update could not be installed because of an error: 2147942405 "Access denied" (Command line: ""C:\Windows\system32\WUSA.exe" "f:\da91add8297ef1ffc885a0\wcu\dotNetFramework\dotnetmsp\x86\NetFX2.0-KB948609-v6001-x86.msu" /quiet /norestart")

     

     

    What I also found is that the setup programs of both the .NET 3.5 SP1 beta as well as that of VS2008 SP1 beta fail on my system when I don't provide an additional drive besides C:\, like a secondary partition or a USB stick. I have more drive letters in my system but those are reserverd for the card reader slots which normally don't contain any media.

    I also tried sfc /scannow and the other things that are recommended in the different blogs mentioned here.

     

    My System: Windows Vista Ultimate SP1 German, Visual Studio 2005 Prof. German, Visual Studio 2008 RTM Prof. English AND German (inkl. several Hotfixes from Connect, the one mentioned by Scott Guthrie of course uninstalled), SQL Server 2008 last CTP Developer Edition, IIS enabled.

     

    Tuesday, May 13, 2008 7:36 PM

Answers

  •  

    My bad. I actively denied the local users group the right to create directories at the root of drive C:. I removed that restriction and now everything seems to work as intended! This was probably also the cause for the error when no additional drive was available.
    Wednesday, May 14, 2008 8:21 AM