none
Error in creating HTTP Recive Adapter for Biztalk 2010 in IIS 7.0 (Windows 7) RRS feed

  • Question

  • I am creating an HTTP Recive Adapter for Biztalk 2010 in IIS 7.0.

    Below are the steps used ;

    1. In the Internet Information Services (IIS) Manager window, in the center pane, in the IIS section, double-click the Handler Mappings icon. In the right pane, click Add Script Map.
    2.  In the Add Script Map dialog box, in the Request path box, enter BTSHTTPReceive.dll. Click the ellipsis (…) next to the Executable box, then browse to C:\Program Files (x86)\Microsoft BizTalk Server 2010\HttpReceive\BTSHTTPReceive.dll, and then click Open.
    3. In the Name box type BizTalk HTTP Receive Adapter, and click OK. In the new Add Script Map dialog box that appears, click Yes.

    After this step i get the following error :

    The specified module required by this handler is not in the modules list. If you are adding a script Map handler the IsapiModule or the CgiModule must be in the modules list.


    Shailender Singh MCP DOTNET 3.5
    Monday, September 12, 2011 10:19 AM

Answers

  • Hi,

    I just followed the steps in a similar dev environment with win 7 enterprise SP1 and 32-bit was able to configure IIS for HTTP Receive location and it works like charm.

    I would say take a step back and start afresh. The application that I added to the Default web site was HTTPRcvHandler

    See the setting in this screen shot.


    Cheers,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    Blog: http://dpsbali-biztalkweblog.blogspot.com
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.
    Tuesday, September 13, 2011 7:02 AM

All replies

  • Hi,

    Check this for steps to configuring IIS for HTTP Receive location. I think you are trying to configure the receive location.


    Cheers,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    Blog: http://dpsbali-biztalkweblog.blogspot.com
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.
    Monday, September 12, 2011 10:53 AM
  • Thanks for your reply Bali.

     

    I am doing the excact same things as mentione din the link that you have provided.

    I get an error after the setp where we Press Yes to save the Handler and the error i am getting is attached in the image above.


    Shailender Singh MCP DOTNET 3.5
    Monday, September 12, 2011 1:44 PM
  • The steps you are following are for Windows Server 2008 SP2 or Windows Server 2008 R2 and IIS 7.0. Can you confirm what is your OS and also if its 32-bit or 64-bit. If its 64-bit did you run the scripts :

    cscript %SystemDrive%\inetpub\AdminScripts\adsutil.vbs set w3svc/AppPools/Enable32bitAppOnWin64 0
    C:\WINDOWS\Microsoft.NET\Framework64\vX.X.XXXXX>aspnet_regiis.exe -i



    Cheers,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    Blog: http://dpsbali-biztalkweblog.blogspot.com
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.
    Monday, September 12, 2011 2:54 PM
  • Bali i am using Win7 Enterprise SP 1 on 32 bit.
    Shailender Singh MCP DOTNET 3.5
    Monday, September 12, 2011 5:31 PM
  • Hi,

    I just followed the steps in a similar dev environment with win 7 enterprise SP1 and 32-bit was able to configure IIS for HTTP Receive location and it works like charm.

    I would say take a step back and start afresh. The application that I added to the Default web site was HTTPRcvHandler

    See the setting in this screen shot.


    Cheers,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    Blog: http://dpsbali-biztalkweblog.blogspot.com
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.
    Tuesday, September 13, 2011 7:02 AM
  • You can see all the step required to configure the IIS 7.0 for HTTP adapter in this post.


    Don't forget to mark the post as answer or vote as helpful if it does, Regards -Rohit Sharma (http://rohitbiztalk.blogspot.com)
    Wednesday, September 14, 2011 9:37 AM
    Moderator