locked
DSS Authentication configuration fails RRS feed

  • Question

  • Hi--

    when I put in a custom %MSRS\store\SecuritySettings.xml, dsshost.exe says:
    *** Initialization failed in DSS boot loader: Error reading security settings
        file. <SecuritySettings
        xmlns='http://schemas.microsoft.com/robotics/2006/10/security.html'> was
        not expected.

    My %MSRS\store\SecuritySettings.xml is copied straight from http://msdn2.microsoft.com/en-us/library/bb870540.aspx and is:
    Code Snippet

    <?xml version="1.0"?>
    <SecuritySettings xmlns="http://schemas.microsoft.com/robotics/2006/10/security.html">
      <AuthenticationRequired>false</AuthenticationRequired>
      <OnlySignedAssemblies>false</OnlySignedAssemblies>
      <Users />
    </SecuritySettings>


    What am I doing wrong with the SecuritySettings.xml configuration?

    Commenting out the security line as per http://channel9.msdn.com/wiki/default.aspx/Channel9.SecurityFAQ disables authentication as expected (allowing me to move on with the tutorial).

    (I'm an experienced linux user, but new to MSRS.  I'm starting to work through the tutorials, and got stuck right away with this authentication problem on service tutorial 1.)

    Thanks in advance,
    Andrew Stout
    Monday, April 28, 2008 9:05 PM

Answers

All replies

  • Hi Andrew,

     

    Are you using the MRDS 2.0 CTP? if so, take a look here:

    http://forums.microsoft.com/Forums/ShowPost.aspx?PostID=3184825&SiteID=1

     

    Otherwise it should work, check everything again.

     

    Erik

     

    Tuesday, April 29, 2008 10:51 AM
  • That's what I did to begin with--I am using MRDS 2.0 CTP, and I'd already followed the instructions in the linked post.  I tried again, just to make sure: same result.  Any other suggestions?
    Sunday, May 4, 2008 7:58 PM
  • Strike that!  I hadn't noticed the DATE CHANGE in the schema--that fixed it.  Thanks!
    Sunday, May 4, 2008 8:03 PM