none
Error When Adding Copy of Existing Package RRS feed

  • Question

  • When I attempt to add an existing package from one of our servers (the packages are stored directly on a SQL Server instance), the following error message appears:

    Invalid class string (Exception from HRESULT: 0x800401F3 (CO_E_CLASSSTRING)) (Microsoft.SqlServer.DTSRuntimeWrap)

    The error appears after I have selected SQL Server for the package location, entered the server name, and selected Windows Authentication for the authentication type.  This process has worked successfully in the past, all the way up until yesterday when the error message first appeared.  I am using Visual Studio 2017 as well as SQL Server 2017 and SSDT release version 15.9.1. 

    I've spent a good three hours searching for answers on the web related to this issue.  There are answers related to the exception, but none that actually pertain to adding copies of existing packages to an Integrated Services project.  Can anyone help with this?

    Thursday, May 2, 2019 10:29 PM

All replies

  • https://stackoverflow.com/questions/5118243/how-to-move-an-ssis-package-from-one-server-moved-to-another

    copy ssis packages as mention in above article.


    https://social.technet.microsoft.com/wiki/contents/articles/37872.sql-server-installation-on-centos-linux.aspx

    Friday, May 3, 2019 6:29 AM
  • Thanks for the reply, Av111.  Unfortunately, I already tried what was suggested in that Stack Overflow article and it did not work - the same error message appears.
    Friday, May 3, 2019 4:49 PM
  • So, there is no one out there who has ever encountered this kind of issue/error before???  I have tried just about everything I can think of, from uninstalling literally every piece of VS, SSDT, and SQL Server to having my laptop reimaged and STILL this error message keeps popping up when I try to simply add an existing package in SSIS and click on the package path to choose from packages that are on a specific server.  It worked until about three weeks ago and now does not.  Why is there an issue every time a new version of SSDT is released?  And why is this issue persisting even after having the registry wiped of keys related to SSDT, Integration Services, and even wiped for completely fresh reinstall of SQL Server, Visual Studio, and SSDT?  If anyone has any other suggestions, PLEASE HELP!!
    Friday, May 10, 2019 3:09 AM
  • I've been fighting the same problem all day today while editing an existing SSIS package and trying to save a copy back to the SQL Server instance. I completely uninstalled all SQL related applications and drivers, all of it, and reinstalled cleanly. Still having the issue. This is garbage.
    Monday, May 13, 2019 8:38 PM
  • I am seeing exactly this problem right now as well.  The source package is coming from SQL Server v2012, the import is trying to go into v2017.  Anybody?
    Friday, June 7, 2019 9:55 PM
  • Seeing the exact same issue. In my case existing SQL Server Standard 2012 to brand new installed SQL Server Standard 2012.

    I am also running Visual Studio 2019 with C# .NET Core 2.2. My guess is that the Core Microsoft.SqlServer.ManagedDTS DLL is not compatible with the non-Core version that SSMS is expecting?

    For reference: https://stackoverflow.com/questions/38791987/how-to-run-ssis-package-in-asp-net-core-application.

    Is anyone with the issue also using .NET Core DLLs? That would indicate something.

    Tuesday, July 16, 2019 5:55 PM
  • Hi, Just a long shot, did you manage to resolve this issue, i'm having the exact same one currently?

    Thanks,

    Si

    Friday, August 2, 2019 8:08 AM
  • I am seeing the same issue, did all of the same steps (uninstall, reinstall, etc.).  There has to be a fix out there by now, doesn't there?

    M C Richardson Remarqable IT

    Friday, August 9, 2019 11:38 AM