locked
How to open Sharepoint 2010 Site in Sharepoint 2010 Designer? RRS feed

  • Question

  • Hi,

    I'm trying to open my site in sharepoint designer 2010.

    I've read a forum that in order to open it in the Sharepoint designer, you must extend your web app. After i've extended my web app my site can now be open in sharepoint designer. But when i've close it then tried to open it again. It wasn't opening again. No error message or anything. Then i've tried to open my Web app extension it promt "Path does not exist".

    Does any body know how to resolve this problem?

    Thanks! :)

    Friday, April 15, 2011 2:11 AM

Answers

  • 1. Open "regedit"
    2. Go to: HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Internet
    3. Create a new DWORD entry called BasicAuthLevel
    4. Set its Hex value to 2
    Note: If Internet(folder) does not exist, you can add this by Right Click Add>Key then name it as Internet on the Common node.
    • Marked as answer by Check'on'it Monday, July 11, 2011 7:18 AM
    Monday, July 11, 2011 7:18 AM

All replies

  • Hello,

    If you want to open your site in Designer 2010 just copy the URL of your site. Now open the designer 2010 where you will get an option to open a site, click it and paste your site address in "Site Name" and when you copy it just remove the .default.aspx extension for the URL.

    For example if your site URL is http://something/SitePages/Home.aspx

    Enter the following in the designer URL http://something

     

    Hope the information helps and please let us know the outcome.


    Thanks & Regards, Chandra Shekhar Rameneni
    Friday, April 15, 2011 5:21 AM
  • Thats what I've been doing...
    Friday, April 15, 2011 5:32 AM
  • Hello,

    OK.

    Please go through this link, it might help you:

    http://social.technet.microsoft.com/Forums/en-US/sharepoint2010customization/thread/76faeebb-6ba2-4289-a8a9-35649558799a/


    Thanks & Regards, Chandra Shekhar Rameneni
    Friday, April 15, 2011 5:55 AM
  • Hi,

     

    Do you see any error?

     

    Have you checked web application's property on enabling SPD 2010?


    Pathik Rawal My Blog
    Friday, April 15, 2011 6:20 AM
  • there's no error in it... no error even in Event Viewer...

    And it's enable in sharepoint designer... >.<

     

    Friday, April 15, 2011 6:45 AM
  • Check the url for that site was also in Alternate Access Mapping. If you map the ipadderess or url to sharepoint site, You have to map that by using Alternate Access Mapping. Then you can access the site using SharePoint Designer, otherwise you will get error.

    I'll hope this will help


    Regards,
    Shantha Kumar .T | MCPD - SharePoint Developer 2010 | MCITP - SharePoint Administrator 2010 |
    (B) Shantha Kumar's Blog | (T)Follow me | (C) IOTAP
    • Marked as answer by Wayne Fan Thursday, April 21, 2011 5:11 AM
    • Unmarked as answer by Check'on'it Monday, July 11, 2011 7:17 AM
    Friday, April 15, 2011 7:02 AM
  • Hi,

        

       1. Please check alternate access mapping url is entered correctly

       2.  please add the hostheader in IIS if the extended site name like http://test.com instead of hostname http://machinename and also add the like the below entry in host file in the machine or add the new host record in the DNS server

    127.0.0.1              test.com

     

    3. Disable the loop back check on the machine.

    Hopes it may be helpful for your reference

    Thanks

    A.Ramu from IOTAP

    http://www.iotap.com

    http://aurramu.blogspot.com

     

     

     

    • Marked as answer by Wayne Fan Thursday, April 21, 2011 5:11 AM
    • Unmarked as answer by Check'on'it Monday, July 11, 2011 7:17 AM
    Friday, April 15, 2011 1:54 PM
  • If the URL is not working, you can test it via the IP of the Domain Name. It could be a DNS resolution issue. Ex. If ABCompany.com has an IP at 55.555.55.5 you would use the address of http://55.555.55.5/Sitename/
    My Company Blog: http://blog.concurrency.com/author/krusk
    My Personal Blog:http://thebitsthatbyte.com
    • Marked as answer by Wayne Fan Thursday, April 21, 2011 5:11 AM
    • Unmarked as answer by Check'on'it Monday, July 11, 2011 7:16 AM
    Friday, April 15, 2011 1:57 PM
  • 1. Open "regedit"
    2. Go to: HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Internet
    3. Create a new DWORD entry called BasicAuthLevel
    4. Set its Hex value to 2
    Note: If Internet(folder) does not exist, you can add this by Right Click Add>Key then name it as Internet on the Common node.
    • Marked as answer by Check'on'it Monday, July 11, 2011 7:18 AM
    Monday, July 11, 2011 7:18 AM