locked
web.config rules Wordpress Permalink RRS feed

  • Question

  • User269763247 posted

    wordpress site not showing inner pages, It show only home page and wordpress admin page. While click save changes in "Permalink Settings" it show "You should update your web.config now."

    web.config 

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
      <system.webServer>
        <rewrite>
          <rules>
    			<rule name="WordPress: http://test.com" patternSyntax="Wildcard">
    				<match url="*"/>
    					<conditions>
    						<add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true"/>
    						<add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true"/>
    					</conditions>
    				<action type="Rewrite" url="index.php"/>
    			</rule></rules>
        </rewrite>
      </system.webServer>
    </configuration>



    Tuesday, August 27, 2019 3:07 AM

All replies

  • User-848649084 posted

    Hi,

    Add below code in your web.config file:

    <?xml version="1.0" encoding="utf-8"?>
    <configuration>
        <system.webServer>
            <rewrite>
                <rules>
                    <rule name="Main Rule" stopProcessing="true">
                        <match url=".*" />
                        <conditions logicalGrouping="MatchAll">
                            <add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
                            <add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" />
                        </conditions>
                        <action type="Rewrite" url="index.php" />
                    </rule>
                </rules>
            </rewrite>
            <staticContent>
                <remove fileExtension=".svg" />
                <mimeMap fileExtension=".svg" mimeType="image/svg+xml" />
            </staticContent>
            <defaultDocument>
                <files>
                    <remove value="index.aspx" />
                    <add value="index.php" />
                </files>
            </defaultDocument>
        </system.webServer>
    </configuration>

    if you get 500 error then remove the  <defaultDocument> part from the config file.

    and make sure you enable iis CGI feature and your WordPress site have enough permission for the iis_iusrs and iusr. 

    Best Regards,

    Jalpa

    Wednesday, August 28, 2019 2:09 AM
  • User269763247 posted

    I have tried the method The problem still exists

    Thursday, August 29, 2019 12:55 PM
  • User-848649084 posted

    Hi,

    are you histed WordPress site as application or site? where did you out your web.config file? 

    Friday, August 30, 2019 5:49 AM
  • User-848649084 posted

    did you installed the url rewrite extension? 

    Friday, August 30, 2019 5:51 AM
  • User-1760500009 posted

    What should be added for utf-8 characters?

    Hi,

    Add below code in your web.config file:

    <?xml version="1.0" encoding="utf-8"?>
    <configuration>
        <system.webServer>
            <rewrite>
                <rules>
                    <rule name="Main Rule" stopProcessing="true">
                        <match url=".*" />
                        <conditions logicalGrouping="MatchAll">
                            <add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
                            <add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" />
                        </conditions>
                        <action type="Rewrite" url="index.php" />
                    </rule>
                </rules>
            </rewrite>
            <staticContent>
                <remove fileExtension=".svg" />
                <mimeMap fileExtension=".svg" mimeType="image/svg+xml" />
            </staticContent>
            <defaultDocument>
                <files>
                    <remove value="index.aspx" />
                    <add value="index.php" />
                </files>
            </defaultDocument>
        </system.webServer>
    </configuration>

    if you get 500 error then remove the  <defaultDocument> part from the config file.

    and make sure you enable iis CGI feature and your WordPress site have enough permission for the iis_iusrs and iusr. 

    Best Regards,

    Jalpa

    Thursday, April 16, 2020 4:51 AM
  • User-1760500009 posted

    my problem solved using this link

    Configuring the FastCGI Extension in IIS for UTF-8 | Microsoft Docs

    Thursday, January 21, 2021 5:52 AM
  • User572594905 posted

    Hi there,

    I'm facing same issue, can you let me know what action did you take? there are some on that link!

    Thanks!

    Tuesday, March 16, 2021 5:51 PM