locked
Unable to access Monitor & Control of Azure Data Factory RRS feed

  • Question

  • I am unable to access the Monitor & Control part of the Azure Data Factory. When I use chrome to access it, it displays the following error message:

    "

    Unknown Error
    An unknown error occured for the following resource: gateways in fvanoostromDataFactory factory. Please contact the administrator of the fvanoostromDataFactory data factory.

    "

    (No gateways are present in the datafactory)

    In Edge and Internet Explorer, it fails to get past the the start-up box containing the text Data Factory and a blinking 'authorizing'

    Other users with the same rights do not have this issue, while I face this issue on multiple data factories accross multiple subscriptions. I have used someone elses computer to log in, and then I do have access. However, I am unable to make sure that it's actually my account that is being used to gain access to the data factory

    edit:clearing cache does not work


    Monday, March 6, 2017 2:46 PM

All replies

  • Hello,

    I would recommend that you use the IE explorer or in its default Edge if you have Windows 10, besides settling them to accept the policy of the Azure environment.
    You should not have any problems if you say you have tried it on other PCs and it worked correctly.

    Greetings.

    Thursday, March 16, 2017 12:56 PM
  • Hi Ferdinand,

    We are aware of this issue. It happens when your authorization session expires. Reopening the browser and providing your credentials again should fix it.

    Thanks,

    Hermine

    Tuesday, April 4, 2017 7:26 PM
  • This doesn't fix the issue at all - either using IE, EDGE or logging back in.

    The problem is when you deploy your data factory via powershell, for some reason it's expecting a gateway object before it can continue. It works if you deploy through the portal (at least for DB->DB, haven't tested API -> DB)

    This is super annoying and pretty badly unit tested for Azure, have you ever tried re-running 1000's of failed slices manually? Yeah.. you should look into the actual problem before saying "turn it off and on again"

    Tuesday, June 27, 2017 9:49 PM
  • Ok, we spent six weeks working with Microsoft support on this one and found a solution to Chrome.

    • Chrome
    • Settings
    • Advanced
    • Content Settings
    • Cookies

    We had Block third-party cookies set to On.  You can EITHER

    1. Turn off Block third-party cookies
    2. Add https://login.microsoftonline.com

    It should then work just fine.



    Wednesday, September 20, 2017 3:03 AM