locked
Visual Studio 2010

    General discussion

  • Visual Studio 2010 does not seem to work on the new Windows 8 Developer Preview. I click on Open Project and it does nothing.
    • Moved by BillFillMicrosoft employee Thursday, September 15, 2011 12:48 AM tools question (From:Windows Developer Preview: General OS questions )
    Wednesday, September 14, 2011 8:30 PM

All replies

  • Hi,

    You can only develop tailored applications using the Visual Studio 11 Preview.  To clarify, are you asking whether you can install Visual Studio 2010 and open 2010 projects on the Windows 8 Developer Preview?

     

    Thanks!

    -Fiona

    Wednesday, September 14, 2011 10:50 PM
  •  

    I installed the x64 version without Visual Studio 11, i installed VS2010 Ultimate, then installed VS2010 SP1 and made sure every update is installed via Windows Update.

    Whenever i open VS and click Open Project it just does a strange flicker and no load screen opens, same happens when i go via the menu. I managed to get it working by dragging my programs solution file into VS and it loaded it. I can't click on the solution and project file of my program, for some reason the file types have not been assigned to VS.

    I can use Create New Project and "Connect to Team Foundation Server" fine just not "Open Project..."

    I have tried completely removing VS and re-install it and the issue still occurs, i've also tried repairing the installation.

     

    P.S.

    Also, probably unrelated... I have the latest Google Chrome Beta browser installed and that won't let me download files, it doesn't show the "Save File" prompt when trying to download files, it works in an fully up-to-date (LDR-QFE Hotfixes) Windows 7 so that issue is only with Windows 8.

     

    Thanks!

     

    UPDATE: Now that i finally managed to get my project to load (by drag & drop), my program can't run. It says..

    Could not load file or assembly 'System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.






    • Edited by Legolash2o Wednesday, September 14, 2011 11:33 PM
    Wednesday, September 14, 2011 11:16 PM
  • So to reiterate, you have a *clean* x64 Win8 machine with only VS2010 SP1, yes? You are trying to create a new project in VS2010 SP1 and the New Project Dialog won't even appear. When you drag/drop existing projects, they load but reference resolution is failing. Is this correct? Could you verify that the following files exist on your box:

    \Program Files\Reference Assemblies\Microsoft\Framework\.NETFramework\v4.0\System.Drawing.dll

    \Windows\Microsoft.NET\Framework\v4.0.30319\System.Drawing.dll

    Thursday, September 15, 2011 9:19 PM
  • Hi Legolash2o,

     

    could we see if fuslogvw helps us understand the binding failures - open a VS 2010 command prompt, type in fuslogvw, go to settings, select log bind failures to disk, select ok.  Click on Open Project.  Go back to fuslogvw and click on Refresh.  Are there any entries for devenv.exe e.g. System.Drawing,etc?  If so, double click on the entry. 

    thanks!

    mike

    Microsoft Developer Support

    Friday, September 16, 2011 12:01 AM
    Moderator
  • Monday, September 19, 2011 5:06 PM
  • Richa, the dude said he has VS 2010 installed along WITH the sp1 (since you can't open a project with just the service pack) AND he has VS 11 installed. The other questions might be significant if the attempt to install wasn't successful. But I figured I needed to clarify. I think that a good question to ask, however, is what version of VS did Legolash2o attempt to open the project in and, if needed to ask, what version of VS was the project originally created on. But, in all honesty, I can pretty much determine without inquiring that the project he's trying to open was created using VS 2010 before installing Windows 8 Consumer Preview and now, with VS 2010 reinstalled and VS 11 installed for the first time, he's attempting to open his previously created project with VS 2010 since that relies on the .NET 4.0 (provided he didn't create the project in an earlier .NET version)....

    p.s. I'm having a very similar issue. I am able to choose 'open with' and select VS 2010 for my .NET 4.0 project. And I receive an error message. (not surprised since I did the research and found that .NET 4.5 replaces 4.0 rather than works side by side. And now Legolash2o and my projects have to figure out what the heck happened to the 4.0 it relied on).

    So, a question 'I' have (likely the same question Legolash2o has) is how can we successfully open a rVS 2010 project now that we have used Windows Update to upgrade to the .NET 4.5 Framework? Fiona Fung MSFT indicated that it is possible by tailoring the application. I would imagine that she means allowing VS 11 to convert the project to the .NET 4.5.. Though I cannot say for sure what she's thinking..

    Sunday, March 25, 2012 8:20 PM