none
C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\applaunch.exe.config is not installed on the system RRS feed

  • Question

  • Hello,

    I have encoutered a problem which let me to use .net setup verifier.

    The log shows several warnings. One is included in the subject bar.

    Reinstalling .net4.0 wont work. Display shows .net4.0 is already installed

    Wednesday, October 30, 2013 10:07 AM

All replies

  • Please share the results of running the .NET Framework Setup Verifier from the tool log.

    Run the verifier with .NET 4.0 selected, then post the first 15 lines AND the LAST 15 lines of the tool log here.

    Also, please share your Windows version.

    Wednesday, October 30, 2013 12:00 PM
  • ======================================================================
    [10/30/13,10:35:45] Beginning of new SetupVerifier activity logging session
    [10/30/13,10:35:45] Activity log file location: C:\Users\NCORNE~1.ICN\AppData\Local\Temp\setupverifier_main_10-30-13_10.35.45.txt
    [10/30/13,10:35:45] Error log file location: C:\Users\NCORNE~1.ICN\AppData\Local\Temp\setupverifier_errors_10-30-13_10.35.45.txt
    [10/30/13,10:35:45] Build created on September 10, 2012
    [10/30/13,10:35:45] Detected operating system: Windows 8 (x64)
    [10/30/13,10:35:45] For more information about repairing the .NET Framework, see http://support.microsoft.com/kb/2698555 and http://go.microsoft.com/fwlink/?LinkID=246062
    [10/30/13,10:35:45] Install state for .NET Framework 1.0: not installed.
    [10/30/13,10:35:45] Install state for .NET Framework 1.1: not installed.
    [10/30/13,10:35:45] Install state for .NET Framework 2.0: installed with service pack 2.
    [10/30/13,10:35:45] Install state for .NET Framework 3.0: installed with service pack 2.
    [10/30/13,10:35:45] Install state for .NET Framework 3.5: installed with service pack 1.
    [10/30/13,10:35:45] Install state for .NET Framework 4 Client: installed with no service packs.
    [10/30/13,10:35:45] Install state for .NET Framework 4 Full: installed with no service packs.
    [10/30/13,10:35:45] Install state for .NET Framework 4.5: installed with no service packs.
    [10/30/13,10:35:45] Windows directory: C:\WINDOWS
    [10/30/13,10:35:45] System directory: C:\WINDOWS\system32
    [10/30/13,10:35:45] Program Files directory: C:\Program Files (x86)
    [10/30/13,10:35:45] Common Files directory: C:\Program Files (x86)\Common Files
    [10/30/13,10:35:45] Not adding product '.NET Framework 1.0' because it is not currently installed
    [10/30/13,10:35:45] Not adding product '.NET Framework 1.1' because it is not currently installed
    [10/30/13,10:35:45] Not adding product '.NET Framework 1.1 SP1' because it is not currently installed
    [10/30/13,10:35:45] Not adding product '.NET Framework 2.0' because it is not currently installed
    [10/30/13,10:35:45] Not adding product '.NET Framework 2.0 SP1' because it is not currently installed
    [10/30/13,10:35:45] Not adding product '.NET Framework 3.0' because it is not currently installed
    [10/30/13,10:35:45] Not adding product '.NET Framework 3.0 SP1' because it is not currently installed
    [10/30/13,10:35:45] Not adding product '.NET Framework 3.5' because it is not currently installed
    [10/30/13,10:35:54] Starting verification for product .NET Framework 4.5
    [10/30/13,10:35:54] Section [Files - .NET Framework 4 Client (Common)] - start parsing entries

    [10/30/13,10:36:01] Key: HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full
    Value: Install
    Expected Data: 1
    Actual Data: 1
    [10/30/13,10:36:01] Key: HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full
    Value: InstallPath
    Actual Data: REGISTRY VALUE FOUND
    [10/30/13,10:36:01] Key: HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full
    Value: Servicing
    Actual Data: REGISTRY VALUE FOUND
    [10/30/13,10:36:01] Key: HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full
    Value: TargetVersion
    Expected Data: 4.0.0
    Actual Data: 4.0.0
    [10/30/13,10:36:01] Key: HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full
    Value: Version
    Actual Data: REGISTRY VALUE FOUND
    [10/30/13,10:36:01] Section [Registry - .NET Framework 4 Full (Wow6432Node)] - stop parsing entries
    [10/30/13,10:36:01] Not running action 'Registry - .NET Framework 4.5 (32-bit)' for product '.NET Framework 4.5' because the OS condition does not match
    [10/30/13,10:36:01] Section [Registry - .NET Framework 4.5 (64-bit)] - start parsing entries
    [10/30/13,10:36:01] Section [Registry - .NET Framework 4.5 (64-bit)] - stop parsing entries
    [10/30/13,10:36:01] Section [Registry - .NET Framework 4.5 (Wow6432Node)] - start parsing entries
    [10/30/13,10:36:01] Key: HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full
    Value: Release
    Actual Data: REGISTRY VALUE FOUND
    [10/30/13,10:36:01] Section [Registry - .NET Framework 4.5 (Wow6432Node)] - stop parsing entries
    [10/30/13,10:36:01] Processing custom action 'Custom Action - .NET Framework 4.0 test application'
    [10/30/13,10:36:01] ExecutablePath = 'Netfx40TestApplication.exe'
    [10/30/13,10:36:01] FriendlyName = '.NET Framework 4 test application'
    [10/30/13,10:36:01] TimeoutSeconds = '300'
    [10/30/13,10:36:01] WaitOnExit = 'true'
    [10/30/13,10:36:01] Silent = 'true'
    [10/30/13,10:36:01] Launching process 'Netfx40TestApplication.exe' now
    [10/30/13,10:36:01] Process successfully launched. Waiting 300 seconds for it to complete.
    [10/30/13,10:36:01] Process 'Netfx40TestApplication.exe' exited with return code 0
    [10/30/13,10:36:01] Verification succeeded for product .NET Framework 4.5

    Wednesday, October 30, 2013 12:20 PM
  • WIN8.1
    Wednesday, October 30, 2013 12:28 PM
  • The verifier shows .NET 4.0 as installed on your system, as would be expected because 4.0/4.5 comes as part of Win 8.1.

    It appears that you ran the verifier with .NET 4.5 selected? Please rerun with 4.0 selected, then post the LAST 15 lines of the tool log here.

    Can we assume that you searched the folder cited in the error message with File Explorer configured to show hidden and system files and failed to find applaunch.exe.config?


    • Edited by pvdg42 Wednesday, October 30, 2013 9:35 PM
    Wednesday, October 30, 2013 12:45 PM
  • Rerun verifier with 4.0full

    [10/30/13,14:03:29] Beginning of new SetupVerifier activity logging session
    [10/30/13,14:03:29] Activity log file location: C:\Users\NCORNE~1.ICN\AppData\Local\Temp\setupverifier_main_10-30-13_14.03.29.txt
    [10/30/13,14:03:29] Error log file location: C:\Users\NCORNE~1.ICN\AppData\Local\Temp\setupverifier_errors_10-30-13_14.03.29.txt
    [10/30/13,14:03:29] Build created on September 10, 2012
    [10/30/13,14:03:29] Detected operating system: Windows 8 (x64)
    [10/30/13,14:03:29] For more information about repairing the .NET Framework, see http://support.microsoft.com/kb/2698555 and http://go.microsoft.com/fwlink/?LinkID=246062
    [10/30/13,14:03:29] Install state for .NET Framework 1.0: not installed.
    [10/30/13,14:03:29] Install state for .NET Framework 1.1: not installed.
    [10/30/13,14:03:29] Install state for .NET Framework 2.0: installed with service pack 2.
    [10/30/13,14:03:29] Install state for .NET Framework 3.0: installed with service pack 2.
    [10/30/13,14:03:29] Install state for .NET Framework 3.5: installed with service pack 1.
    [10/30/13,14:03:29] Install state for .NET Framework 4 Client: installed with no service packs.
    [10/30/13,14:03:29] Install state for .NET Framework 4 Full: installed with no service packs.
    [10/30/13,14:03:29] Install state for .NET Framework 4.5: installed with no service packs.
    [10/30/13,14:03:29] Windows directory: C:\WINDOWS
    [10/30/13,14:03:29] System directory: C:\WINDOWS\system32
    [10/30/13,14:03:29] Program Files directory: C:\Program Files (x86)
    [10/30/13,14:03:29] Common Files directory: C:\Program Files (x86)\Common Files
    [10/30/13,14:03:29] Not adding product '.NET Framework 1.0' because it is not currently installed
    [10/30/13,14:03:29] Not adding product '.NET Framework 1.1' because it is not currently installed
    [10/30/13,14:03:29] Not adding product '.NET Framework 1.1 SP1' because it is not currently installed
    [10/30/13,14:03:29] Not adding product '.NET Framework 2.0' because it is not currently installed
    [10/30/13,14:03:29] Not adding product '.NET Framework 2.0 SP1' because it is not currently installed
    [10/30/13,14:03:29] Not adding product '.NET Framework 3.0' because it is not currently installed
    [10/30/13,14:03:29] Not adding product '.NET Framework 3.0 SP1' because it is not currently installed
    [10/30/13,14:03:29] Not adding product '.NET Framework 3.5' because it is not currently installed
    [10/30/13,14:03:35] Starting verification for product .NET Framework 4 Full
    [10/30/13,14:03:35] Section [Files - .NET Framework 4 Client (Common)] - start parsing entries

    [10/30/13,14:03:37] Key: HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full
    Value: Version
    Actual Data: REGISTRY VALUE FOUND
    [10/30/13,14:03:37] Section [Registry - .NET Framework 4 Full (Wow6432Node)] - stop parsing entries
    [10/30/13,14:03:37] Processing custom action 'Custom Action - .NET Framework 4.0 test application'
    [10/30/13,14:03:37] ExecutablePath = 'Netfx40TestApplication.exe'
    [10/30/13,14:03:37] FriendlyName = '.NET Framework 4 test application'
    [10/30/13,14:03:37] TimeoutSeconds = '300'
    [10/30/13,14:03:37] WaitOnExit = 'true'
    [10/30/13,14:03:37] Silent = 'true'
    [10/30/13,14:03:37] Launching process 'Netfx40TestApplication.exe' now
    [10/30/13,14:03:37] Process successfully launched. Waiting 300 seconds for it to complete.
    [10/30/13,14:03:37] Process 'Netfx40TestApplication.exe' exited with return code 0
    [10/30/13,14:03:37] Verification succeeded for product .NET Framework 4 Full

    Wednesday, October 30, 2013 1:05 PM
  • searched by file explorer and found the file 3 times

    - c:\windows\micorsoft.net\framework64\v4.0.30319

    - c:\windows\winsxs\amd64_netfx4-applaunch_exe_..

    - c:\windows\winsxs\x86_netfx4-applaunch_exe_b03..

    Wednesday, October 30, 2013 1:22 PM
  • I found the file four times and all files are identical is size and content.

    As the setup verifier indicates that your .NET 4.0 is installed and configured correctly, I suggest that you make a copy of the applaunch.exe.config you have in c:\windows\micorsoft.net\framework64\v4.0.30319, and put it in c:\windows\micorsoft.net\framework\v4.0.30319 and see if that helps.

    Wednesday, October 30, 2013 9:47 PM
  • I will reinstal my laptop to solve the problem.

    Cleaning the .nets wont work

    Thanks for the help

    Monday, November 4, 2013 8:54 AM