locked
Xamarin doesn't ignore whitespace in declaration statements on formatting RRS feed

  • Question

  • User162696 posted

    Argh .. I am a big fan of alignment. Can anybody help me with this.

    <ocd> var MyVar = "Some content"; var MyOtherVar = "Some content"; var MySomeYetotherVar = "Some content"; var MyVar = "Some content"; </ocd>

    As opposed to

    <noneocd > var MyVar = "Some content"; var MyOtherVar = "Some content"; var MySomeYetotherVar = "Some content"; var MyVar = "Some content"; </noneocd>

    Which is much more readable

    I turned 'ignore spaces in declaration statements on' but when I reformat all my neatly indented code get's modified.

    Thursday, February 9, 2017 9:36 AM

All replies

  • User21936 posted

    @Ryan-vd-W

    Hmm, maybe try changing the indentation mode? In Xamarin Studio->Preferences dialog, select the Text Editor->Behavior section. There you will see an Indentation Mode field with 3 available options "None," "Automatic," and "Smart." Try Automatic. Both "None" and "Automatic" seem to resolve the issue of these "indents" (not technically indents per se as I think that refers to line indentation) being changed. However the "None" option won't do line indents then while "Automatic" still does proper line indenting.

    Wednesday, February 15, 2017 12:22 AM