none
Invalid character in data element RRS feed

  • Question

  • I am receiving an 820 with the following RMR segment. 

     

    RMR*IV*WE:0426-209894*PO*897.60*897.60*0.00

     

    I have tried all the settings, “Allow Leading and Trailing Zeroes and Spaces” on the party and disabling “EDI Validation” on the receive port.,  but I continue to get the below error.

     

     

    In BizTalk 2006 R2

    --------------------------------

     

    Error encountered during parsing. The X12 transaction set with id '000015488' contained in functional group with id '4020', in interchange with id '0000011111', with sender id '00222222      ', receiver id 'TESTID      ' is being suspended with following errors:

     

    Error: 1 (Field level error)

                    SegmentID: RMR

                    Position in TS: 8

                    Data Element ID: RMR02

                    Position in Segment: 2

                    Data Value:

                    6: Invalid character in data element

     

    Error: 2 (Field level error)

                    SegmentID: RMR

                    Position in TS: 11

                    Data Element ID: RMR02

                    Position in Segment: 2

                    Data Value:

                    6: Invalid character in data element

     

    Any help would be greatly appreciated.

     

    Thanks

    Tom

     

    Tuesday, September 1, 2009 5:56 PM

Answers

  • Tom,

    There is no way around it, other than pre-processing the file to replace the colon.  Often this is caused by bad data entry processes, where the person entering data into the database doesn't know they should not use a colon, in which case your trading partner may encounter this problem with more folks than you.

    Give your partner a call and suggest they change the ISA16 to a tilde '~', for example, or any character that is unlikely to be typed into a text field.

    In the worst case, a simple pipeline component to replace the colon is not difficult to put together.

    Hope this helps




    Jim -- Pro Mapping in BizTalk 2009, Apress Books, March 23, 2009
    • Marked as answer by ParahT Tuesday, September 1, 2009 7:38 PM
    Tuesday, September 1, 2009 6:59 PM

All replies

  • Tom,

    Check the ISA for this transaction and make sure that the colon ':' is not being used as the sub-element separator (ISA16).  If it is, the colon can not be used in the text of the message.


    Jim -- Pro Mapping in BizTalk 2009, Apress Books, March 23, 2009
    Tuesday, September 1, 2009 6:01 PM
  • Jim,

    yes the ':' is being used on the ISA16

    ISA*00*          *00*          *01*00222222       *ZZ*TESTID      *090824*0512*U*00401*000001541*0*P*:

    is there any way around this or will I have to request our trading partner update their file?

    Thanks
    Tom
    Tuesday, September 1, 2009 6:53 PM
  • Tom,

    There is no way around it, other than pre-processing the file to replace the colon.  Often this is caused by bad data entry processes, where the person entering data into the database doesn't know they should not use a colon, in which case your trading partner may encounter this problem with more folks than you.

    Give your partner a call and suggest they change the ISA16 to a tilde '~', for example, or any character that is unlikely to be typed into a text field.

    In the worst case, a simple pipeline component to replace the colon is not difficult to put together.

    Hope this helps




    Jim -- Pro Mapping in BizTalk 2009, Apress Books, March 23, 2009
    • Marked as answer by ParahT Tuesday, September 1, 2009 7:38 PM
    Tuesday, September 1, 2009 6:59 PM
  • Jim,

    I will make the call.

    Thanks for the fast response.
    Tom
    • Marked as answer by ParahT Tuesday, September 1, 2009 7:38 PM
    • Unmarked as answer by ParahT Tuesday, September 1, 2009 7:38 PM
    Tuesday, September 1, 2009 7:38 PM
  • Sort of related:

    I've had this error a LOT, and it would popup randomly, and for me it was caused for me by the trading partner sending a 'U' in the ISA11 and having biztalk configured to use ISA11 as repetition separator (or vice-versa). Just flip-flop the usage flag for that field in the party's EDI Properties and you should be good. Its not the solution to the colon problem, but it is a similar thing where you have to contact the trading partner and get them to change what they're sending.
    Tuesday, September 8, 2009 5:06 PM