locked
Visual Studio Office 2007 template -> Outlook 2013 RRS feed

  • Question

  • hey, the reading I've done suggests this should work but the instant you create a new project in 2008 using a 2007 template and try to run it, it fails saying the "required version of Office is not installed"

    Can anyone confirm if this is the case?


    • Edited by DaveB-UK Wednesday, April 10, 2013 11:57 AM
    Wednesday, April 10, 2013 11:57 AM

Answers

  • yes, this behaviur is the same for all VS versions - only matching office version is supported. You can Work around this by simply using normal library project (change project type guid in csproj) and set debugging options to start external program (Outlook.exe)
    • Marked as answer by DaveB-UK Thursday, April 11, 2013 11:29 AM
    Wednesday, April 10, 2013 12:29 PM

All replies

  • yes, this behaviur is the same for all VS versions - only matching office version is supported. You can Work around this by simply using normal library project (change project type guid in csproj) and set debugging options to start external program (Outlook.exe)
    • Marked as answer by DaveB-UK Thursday, April 11, 2013 11:29 AM
    Wednesday, April 10, 2013 12:29 PM
  • When you export the add in does it resolve the path to the application somehow...? otherwise it's an absolute path?
    Wednesday, April 10, 2013 1:21 PM
  • I've just found the same problem using VS 2012 and it gave the same error, using a 2010 template?

    Previously I have had an add in created in VS  2008 run perfectly fine in 2007 and 2010?

    Wednesday, April 10, 2013 2:11 PM