none
Could not find installable ISAM RRS feed

  • Question

  • Hi,
    I'm getting the error "Could not find installable ISAM" when I try to connect to an Access .mdb file from my VB .NET 2.0 application.

    I am working on porting an ASP 1.0 application, and it used this .mdb file, so I simply copied the file into my .NET application project directory.

    Here is the code I tried to connect with:

    Code Snippet

    Dim mapPath As String = Server.MapPath("/fpdb/myfile.mdb")
    Dim jetConnStr As String = String.Format("Provider=Microsoft.Jet.OLEDB.4.0;Data Source={0}", mapPath)
    Dim conn As System.Data.OleDb.OleDbConnection = New System.Data.OleDb.OleDbConnection(jetConnStr)
    Try
    conn.Open()
    Catch ex As System.Data.OleDb.OleDbException
    errorMessage.Text = ex.Message
    End Try



    I have read many articles about this error, and followed the instructions I found in http://support.microsoft.com/kb/283881/ but I haven't been able to make any progress.

    I checked the registry as described in the above article, and at all of the keys in the table, there exists an entry similar to

    Name: win32
    Type: REG_SZ
    Data: C:\winnt\system32\msxbde40.dll

    So I assume this means the registry values are correct...what do I do now?  Attempt to repair my Office install, or am I missing something else?
    Wednesday, February 13, 2008 7:41 PM

Answers

  • I would suspect that there is either a problem with your connection string or there is a permissions problem accessing the OLEDB provider. I would verify that there isn't a problem with the connection string first, perhaps hard-code the complete string to see if you can get it functioning without the error.

     

    Wednesday, February 13, 2008 8:42 PM

All replies

  • I would suspect that there is either a problem with your connection string or there is a permissions problem accessing the OLEDB provider. I would verify that there isn't a problem with the connection string first, perhaps hard-code the complete string to see if you can get it functioning without the error.

     

    Wednesday, February 13, 2008 8:42 PM
  • You were right, it was a problem with the connection string.  Thanks for getting me to take another look at that bit!
    Wednesday, February 13, 2008 9:16 PM