locked
Publishing Lightswitch in Visual Studio 2015 RRS feed

  • Question

  • At some point during the process of upgrading to Visual Studio 2015 I can no longer publishing a lightswitch APP that I converted from 2013 to 2015  without choosing to publishing the project first and then right click on the  .Server and choosing to publish that will it finally push my changes to our web server.

    I tried with a fresh clean lightswitch app and it's fine.  So it is something embedded in this solution that won't let me.

    If I try and publish it to a new site, it's supposed to create the site for me.  but all I get is this on the IIS server

    Provider: appHostAuthOverride, Path: Default Web Site/STRUT;anonymousAuthentication=Allow
    A tracing deployment agent exception occurred that was propagated to the client. Request ID 'ca7f08fd-0edc-4279-9fcd-a281efc1e3f9'. Request Timestamp: '4/6/2016 4:31:31 PM'. Error Details:
    ERROR_SITE_DOES_NOT_EXIST

    Microsoft.Web.Deployment.DeploymentDetailedException: Site 'Default Web Site/STRUT' does not exist.  Learn more at: http://go.microsoft.com/fwlink/?LinkId=221672#ERROR_SITE_DOES_NOT_EXIST.

    I don't know what to do.... i can continue to publish the two step way but it seems wrong and I am afraid something important may not be getting pushed to the server.  any thoughts?

    Wednesday, April 6, 2016 8:40 PM

Answers

  • actually this broke it

    <Properties>SkipValidatePackageReferences=true</Properties>

    adding that in is what is causing my app to not publish properly. maybe I am adding that in the wrong place?

    i removed it and all is working well except for that build warning i am getting about installing nuget package

    • Marked as answer by bpwilliams8 Thursday, April 14, 2016 4:22 PM
    Wednesday, April 13, 2016 2:27 PM

All replies