none
Integration Account Control Error RRS feed

  • Question

  • I have been using integration accounts for a few years but on one of my clients the control stopped working a few weeks ago. I have this weird error. It looks like the Integration Account tile is broken. I have tried the Reload tile button but it does not do anything I have also tried cleaning out my browser cache and In-Private browsing. This is happening in both IE Edge and Chrome. Here is the error:

    Part's onInputsSet promise failed.(id: HubsExtension-fx-000-0fe) Error: description: Code: 'incompatibleOptions'. message: Code: 'incompatibleOptions'. stack: ###_RPC_Exception_### Error: Code: 'incompatibleOptions'. at r (https://portal.azure.com/Content/Dynamic/Utj-TW1baCBV.js:18:779) at u (https://portal.azure.com/Content/Dynamic/Utj-TW1baCBV.js:11:1289) at i[n] (https://portal.azure.com/Content/Dynamic/Utj-TW1baCBV.js:11:1526) at r (https://portal.azure.com/Content/Dynamic/Utj-TW1baCBV.js:108:930) at t (https://portal.azure.com/Content/Dynamic/Utj-TW1baCBV.js:108:2731) at n (https://portal.azure.com/Content/Dynamic/Utj-TW1baCBV.js:87:589) at u (https://portal.azure.com/Content/Dynamic/Utj-TW1baCBV.js:111:89) at t (https://afd.hosting.portal.azure.net/ema/Content/Dynamic/8JzUt9ZRlaBM.js:17:1306) at n (https://afd.hosting.portal.azure.net/ema/Content/Dynamic/4UyjHmbQn865.js:2:219) at t (https://afd.hosting.portal.azure.net/ema/Content/Dynamic/4UyjHmbQn865.js:91:6565) From RPC: HubsExtension -> Microsoft_Azure_EMA (MsPortalFx.Internal.Constants.RpcMethods.viewModels) (Callstack capturing is not enabled. Use ?trace=diagnostics to enable it.) 

    I also have seen a similar error on my subscription home for this client. There is another tile that is broken too:

    Part's onInputsSet promise failed.(id: Microsoft_Azure_EMA-fx-000-000) Error: _errorData: {"httpStatusCode":404,"headers":{"Pragma":"no-cache","x-ms-failure-cause":"gateway","x-ms-request-id":"74827049-08a5-429b-8988-d8a019122d39","x-ms-correlation-request-id":"a5219404-47b8-44c5-ae81-17a072055efd","x-ms-routing-request-id":"NORTHCENTRALUS:20190813T043821Z:74827049-08a5-429b-8988-d8a019122d39","Strict-Transport-Security":"max-age=31536000; includeSubDomains","X-Content-Type-Options":"nosniff","Cache-Control":"no-cache","Date":"Tue, 13 Aug 2019 04:38:21 GMT"},"content":{"error":{"code":"ResourceNotFound","message":"The Resource 'MICROSOFT.LOGIC/workflows/DEMO_EDI_APP' under resource group 'LDSINTEGRATION' was not found."}},"contentLength":156} _sourceErrorLevel: undefined baseTypes: ["MsPortalFx.Errors.FetchDataError","MsPortalFx.Errors.DataError","MsPortalFx.Errors.Error"] code: undefined data: undefined dataSetName: EMAExtension.Workflow.Workflow:DataCache:30:2 description: undefined errorLevel: 2 extension: Microsoft_Azure_EMA handled: undefined innerErrors: [] message: name: 

    On Opera for the integration account I am seeing a different error. Apparently there is something wrong with this subscription. 

    Part's onInputsSet promise failed.(id: HubsExtension-fx-000-0cc) Error: message: Code: 'incompatibleOptions'. stack: ###_RPC_Exception_### Error: Code: 'incompatibleOptions'. at new r (https://portal.azure.com/Content/Dynamic/Utj-TW1baCBV.js:18:790) at u (https://portal.azure.com/Content/Dynamic/Utj-TW1baCBV.js:11:1296) at Object.t.forEachKey.i.

    Any ideas on what to do?

    Thanks


    If this answers your question, please use the "Answer" button to say so | Ben Cline


    • Edited by Ben Cline1 Tuesday, August 13, 2019 5:00 AM
    Tuesday, August 13, 2019 4:51 AM

Answers

  • My friends at the company where we got the error identified that these errors are occurring when you have the Contributor but not Owner role for an integration account. Once the Owner role is granted the first and third errors go away. 

    So this is something like a broken link and apparently the integration account control permissions may have recently changed. 

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline

    • Marked as answer by Ben Cline1 Tuesday, August 13, 2019 7:18 PM
    Tuesday, August 13, 2019 7:09 PM