locked
Opening an Excel document in Office 365 RRS feed

  • Question

  • The first time an Excel document was attempted to be opened (on the main desktop computer) a pop up box "External Protocol Request" appeared that asked if the user would like to do nothing or launch the application.  There is also a box that if checked, will remember the choice for all links of the type.  The user check marked the Box with the intent to launch the application.  Instead, they accidentally clicked the Do Nothing button.  Now, Excel will not open in the application, only online.  MS Word works fine because the user selected launch application instead of do nothing.

    This problem is isolated to one computer only, the computer where the action to do nothing was chosen.  The primary browser that is used is Chrome because Internet Explorer 11 crashes when a document is trying to open. 

    I did try to change the site collection features by activating "Open documents in Client Applications by Default" but that did not fix the problem.

    In addition to looking at the site collection, I also looked under protocol_handler these are my options:

    "protocol_handler": {
          "excluded_schemes": {
             "pokki": false

    I didn’t see any options regarding Excel or Office 365.  I had the same problem with Word and the solution has resting user options and registry settings in Word. 

    I have searched through the internet and cannot find a similar solution for Excel.  Do you have a solution like this or a different solution? 

    I hope this is precise enough to help troubleshoot the problem. 

    Thanks again!

    Jennifer

    Monday, June 13, 2016 5:12 PM

All replies

  • Hi Jennifer,

    According to your description, you accidentally set Chrome to not use the Excel Application.

    You can delete the “Local State file” and restart chrome to reset external protocol handler settings in Chrome.

    1. Close Chrome.

    2. Go to %USERPROFILE%\AppData\Local\Google\Chrome\User Data.

    3. Delete the "Local State" file.

    4. Start Chrome and try opening excel again.

    In addition, since this is regarding to Chrome, I suggest you create a thread on Chrome forum for more information.

    Best Regards,

    Linda Zhang


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by jlnvz123 Tuesday, June 14, 2016 10:37 PM
    • Unmarked as answer by jlnvz123 Tuesday, June 14, 2016 10:40 PM
    • Proposed as answer by Paul M Edwards Friday, March 24, 2017 9:02 PM
    Tuesday, June 14, 2016 5:53 AM
  • Hi Jennifer,

    How are things going?

    Do you resolve the issue?

    Best regards,

    Linda Zhang


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, June 15, 2016 1:10 AM
  • I can't answer for Jennifer, but since I had the same problem and your answer lead me to the solution, I will propose it as the answer.

    I personally didn't want to just delete the Local State file, so I instead ensured all instances of Chrome.exe were terminated, opened the file (which is just JSON) in Notepad++, a text editor, found the entry for Excel within the protocol_handler section, and removed only that entry.

    These sites give more specific information and steps for doing so:

    • http://help.suitefiles.com/article/17-chrome-external-protocol-request-configuration
    • https://vsee.zendesk.com/hc/en-us/articles/209804153-How-to-Reset-Protocol-Handler-on-Chrome-VSee-doesn-t-launch-from-waiting-room-
    Friday, March 24, 2017 9:05 PM