none
Lookup troubles in Access Web App RRS feed

  • Question

  • I'm hoping this is the correct forum for my question.
    If not, please point me in the right direction.

    I have an access database I uploaded to SharePoint as a Web App.
    It contains 2 tables, one for users, another for document URLs.
    The document URLs are linked to users by an ID number that already existed before moving to SharePoint.

    My problems are that when I move the database from a working Access DB on my PC to SharePoint, the lookup is broken.

    I would be OK with this if the following worked.

    When I try to copy and paste into the lookup field in the documents table, it will either except only IDs that are 4 or less digits if the field is defined as a number.
    If I define the field as text, I can only successfully paste IDs that have been looked up and manually linked at least once in the documents table.

    Can someone please tell me what I'm missing?

    Wednesday, October 14, 2015 5:02 PM

All replies

  • Hi Charles Keenybrook,

    Are you developing Access 2010 web database or Access 2013 web app? Based on the test, the lookup field works well in Access 2013 web app.

    If you were developing with Access 2010 web database, please check the web compatibility before you publish the database. You can get more detail about error suing loops for web database:
    Web compatibility check: Relationship and Lookup errors

    Regards & Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, October 15, 2015 5:27 AM
    Moderator