none
Project Server 2010 ProjectServerServices dll not loading RRS feed

  • Question

  • I am making a webpart for project server 2010 and compiled a ProjectServerServices dll Proxy Assembly in WCS folder by opening the source folder and with CompileWCFProxyAssembly command. The dll was created and I referred it in my visual studio . The project build fine. On deploying the project the web part is seen in the gallery   but on trying to add it gives an error message 'Could not load file or assembly ProjectServerServices, version=0.0.0.0,culture=neutral,public key token ...or one of its dependencies. the system cannot find the file specified.'.

    I found the ProjectServerServices dll was not in the assembly folder but the error message persists after dragging the dll to the assembly folder.

    What is the right way of making the project server dll. When the dll was created it also created a PsiKey in that folder. My Visual Studio project key is named sn. key. does it make a differnce. What will be solution for assemly loading issue?



    • Edited by geeam Thursday, June 5, 2014 12:25 PM
    Thursday, June 5, 2014 11:54 AM

Answers

  • Right way to make the proxy assembly is documented on TechNet http://msdn.microsoft.com/en-us/library/ff621594%28v=office.14%29.aspx

    have you tried restarting the IIS post DLL registration in GAC ?

    Try redeploying your webpart using powershell with including -GACDeployment -Force parameters, something like as below

    Update-SPSolution -Identity WSPSolName.wsp -LiteralPath ~\Path\WSPSolName.wsp -GACDeployment -Force


    Thanks | epmXperts | http://epmxperts.wordpress.com

    • Marked as answer by geeam Thursday, June 5, 2014 7:39 PM
    Thursday, June 5, 2014 1:13 PM
    Moderator

All replies