none
Itinerary Issue which using Orchestration Extender RRS feed

  • Question

  • Hi all,

    I have develop a application in which i am having receivePort and ReceiveLocation.

    On Receive Port i am using Inbound and OutBound Maps and in orchestration i am using the message and doing some business logic and sending message back, this is working fine.

    Now i am trying to use the Itinerary and shifting my maps and Orchestration Extender in it.

    Can some one help me how to do this ?

    what i am doing is as follows :

    1) OnRamp - > ReivePortName -> BiztalkApplicationName -> OnRamp - > ESB Extender, ServiceName -> Transform.

    2) Itinerary Service ->OnRamp -> receiveInbound -> ServiceName - ESB Service Transform -> MessageExtender

    Resolver ->  TranformType = Transformname -> TransportName - WCF-BasicHttp -> Static Resolver Extender.

    3) Itinerary Service ->Servicename- OrcestrationName -> Is Request Response- True -> Orchestration Extender.

    When trying to run this it's giving me error as :

    The published message could not be routed because no subscribers were found.

    I have removed the maps from Receive Ports. 

    Any idea what this might be ?

    when looked in suspended instance i found that this message is getting transform cause in log event it's shown me Routing Failure Report for "Routing Failure Report for "RcvCatch".

    and in Message tab it's shown me the destination type message. that's it.

    it's look like it's not executing this in Transform only, i have removed the transform and directly call the orchestration and it's worked for me.

    Not sure what issue is ?


    Thanks and Regards, Nitin.

    Wednesday, August 19, 2015 12:47 PM

Answers

  • After the transform ur message type is getting changed. May be because of that u r getting no subscribers.. Chk on the subscription list on the filter for ur process

    Regards <br/> When you see answers and helpful posts,<br/> please click Vote As Helpful, Propose As Answer, and/or Mark As Answer

    • Proposed as answer by Angie Xu Wednesday, August 26, 2015 6:52 AM
    • Marked as answer by Angie Xu Monday, September 14, 2015 12:36 AM
    Friday, August 21, 2015 2:13 PM
    Answerer

All replies

  • it's a little wired, any other hints?
    Friday, August 21, 2015 9:07 AM
  • After the transform ur message type is getting changed. May be because of that u r getting no subscribers.. Chk on the subscription list on the filter for ur process

    Regards <br/> When you see answers and helpful posts,<br/> please click Vote As Helpful, Propose As Answer, and/or Mark As Answer

    • Proposed as answer by Angie Xu Wednesday, August 26, 2015 6:52 AM
    • Marked as answer by Angie Xu Monday, September 14, 2015 12:36 AM
    Friday, August 21, 2015 2:13 PM
    Answerer