locked
Problem in creating accessor for privated methods in test cases in vsts 2010 Ultimate RRS feed

  • Question


  • I followed steps as :

    1 . Installed vsts 2010 ultimate & converted the test project into vsts 2010 ultimate compatible

    2. When I run test case it started throwing the error "Could not load assembly c.dll".

    3. I removed moles Type reference which contains accessor for private method, then build creation success

    4. when i try to add private access in order to create test method for private method it shows "Could not load assembly  someassembly.dll"

    5. Also visual 2010 ultimate is listing only 4.0 in target framework list. How to make it recognize other frameworks too.

    6. Follow below text is copied from output window of vsts

    --- Rebuild All started: Project: AccessorTest, Configuration: Debug Any CPU ------
    C:\Program Files\MSBuild\Microsoft\VisualStudio\v10.0\TeamTest\Microsoft.TeamTest.targets(14,5): error : Could not load file or assembly 'ABB.FI.CDSDispatcherTiger, Version=110.110.9.110, Culture=neutral, PublicKeyToken=5c5a5201ad339044' or one of its dependencies. The system cannot find the file specified.
    ========== Rebuild All: 23 succeeded, 1 failed, 0 skipped ==========

    • Moved by lucy-liu Tuesday, April 10, 2012 7:39 AM it is a unit test issue (From:Visual Studio Extensibility)
    Monday, April 9, 2012 8:18 AM

Answers

  • Hi Mr Subbu,

    Thank you for posting in the MSDN forum.

    I removed moles Type reference which contains accessor for private method, then build creation success

    We want to make sure:

    1. Do you mean that you are run the unit test?
    2. Whether you are using the PEX/ Moles? Actually, we didn’t support it. As the PEX/ Moles team mentioned that they will migrate the forums to stackoverflow.com (http://research.microsoft.com/en-us/projects/pex/), you can visit there.

    If I have misunderstood anything, please make free feel to let us know.

    Have a nice day,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, April 10, 2012 7:53 AM

All replies

  • Hi Subbu,

    I will move it to "Visual Studio Unit Testing" forum for a better support.

    Thank you for your understanding!

    Best regards,

    Lucy


    Lucy Liu [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, April 10, 2012 7:38 AM
  • Hi Mr Subbu,

    Thank you for posting in the MSDN forum.

    I removed moles Type reference which contains accessor for private method, then build creation success

    We want to make sure:

    1. Do you mean that you are run the unit test?
    2. Whether you are using the PEX/ Moles? Actually, we didn’t support it. As the PEX/ Moles team mentioned that they will migrate the forums to stackoverflow.com (http://research.microsoft.com/en-us/projects/pex/), you can visit there.

    If I have misunderstood anything, please make free feel to let us know.

    Have a nice day,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, April 10, 2012 7:53 AM
  • Hi Mr Subbu,

    I mark the answer, please check it. If you need further assistance, please feel free to let us know.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Monday, April 16, 2012 2:36 AM