locked
Projects Created in Visual Web Developer 2010 wont Build in Expression Blend 4 RRS feed

  • Question

  • Just like the title says, anything I create in VWD then try to build in Expression blend throws an error stating this:

    The "Microsoft.WebApplication.Build.Tasks.GetSilverlightItemsFromProperty" task could not be loaded from the assembly c:\Program Files(x86)\MSBuild\Microsoft\VisualStudio\v10.0\WebApplications\Microsoft.WebApplication.Build.Tasks.dll. Could not load file or assembly 'file:///c:\Program Files(x86)\MSBuild\Microsoft\VisualStudio\v10.0\WebApplications\Microsoft.WebApplication.Build.Tasks.dll or one of its dependencies.The system cannot find the file specified.

     

    I've seen other forum postings of people having this issue but no real resolution. Could someone please respond with a fix to this.

     

    Thank you.

    Monday, February 7, 2011 7:57 PM

All replies

  • I've never been able to track down what isn't installed correctly in this case, but there is build targets file missing on the affected system. Something isn't installed correctly, or an sdk is missing someplace.
    Monday, February 7, 2011 8:38 PM
    Moderator
  • Thanks for your reply Chuck. I know you have tried to address this issue in other postings.

    I'v gone through the reinstall process once already. I forgot to mention that when I create a project in Blend, I can open and build the project in both Blend and VWD. It is only when I create a project in VWD that I run into the issue.

     

    Here are the SDKs I have installed.

    Blend 3 SDK

    Blend SDK for Net 4

    Blend SDK for Silverlight 4

    Silverlight 3 SDK

    Silverlight 4 SDK

    Silverlight Toolkit April 2010

    Silverlight Tools for Visual studio 2010

    WCF RIA Services Toolkit

    WCF RIA Services V1.0 for Visual Studio 2010

    Monday, February 7, 2011 8:49 PM
  • If you are willing, one thing that would help is to see the detailed build output from inside VS. You can get this by going to options -> Projects and Solutions -> Build and run, and changing the msbuild project build output verbosity to detailed or diagnostic. If you then do a full rebuild of your project, the output window will contain a huge amount of msbuild output. If you are able, send that to me at first.last@microsoft.com (using my name) and I will see if I can tell why VS can build but Blend can't. I am curious how VS resolves that targets file that msbuild/Blend complain are missing.
    Monday, February 7, 2011 8:54 PM
    Moderator
  • Hello All,

    I'm having the same issue as with MsBuild spitting out the following below build error.  This error comes out from trying to compile a web project hosting a silverlight application.  The VS IDE has no issues compiling the project on the same machine, but using the command line MsBuild directly creates this error.   I believe that I only require the Microsoft.WebApplication.Build.Tasks.dll to complete this build correctly but I can't seem to find it anywhere on the net or through installing components mentioned by Mr. GIS.  Does anyone have  a download link or could send it to me? or have a work around?

    
    
    
    C:\Program Files\MSBuild\Microsoft\VisualStudio\v10.0\WebApplications\Microsoft.WebApplication.targets(244,5): error MSB4062: The "Microsoft.WebApplication.Build.Tasks.GetSilverlightItemsFromProperty" task could not be loaded from the assembly C:\Program Files\MSBuild\Microsoft\VisualStudio\v10.0\WebApplications\Microsoft.WebApplication.Build.Tasks.dll. Could not load file or assembly 'file:///C:\Program Files\MSBuild\Microsoft\VisualStudio\v10.0\WebApplications\Microsoft.WebApplication.Build.Tasks.dll' or one of its dependencies. The system cannot find the file specified. Confirm that the <UsingTask> declaration is correct, that the assembly and all its dependencies are available, and that the task contains a public class that implements Microsoft.Build.Framework.ITask.

    Cheers,

    E

    Wednesday, July 6, 2011 4:06 PM