none
Does .net framework 4.0 contains KB2637518 RRS feed

  • Question

  • My host is Windows 2008 R2 SP1 and has .net framework installed by windows update.

    Now I'm deploy sharepoint development environment.

    When installing a hotfix (kb2637518), please refer to http://www.microsoft.com/en-us/download/details.aspx?id=28949, it prompted "The update is not applicable to your computer". I checked out and found that .net framework 4.0 and .net framework 3.5.1 both have been installed.

    My question: Does .net framework 4.0 already contains that hotfix?

    Thanks!

    Thursday, March 27, 2014 1:41 AM

Answers

  • There are instructions in this article to help you check for the KB:

    http://support.microsoft.com/kb/2647518

    Specifically:

    "To verify that the update was applied.



    • Microsoft Baseline Security Analyzer

      To verify that a security update was applied to an affected system, you may be able to use the Microsoft Baseline Security Analyzer (MBSA) tool. See the "Detection and Deployment Tools and Guidance" section for more information.
    • Registry subkey verification

      You may also be able to verify the files that this security update has installed by reviewing the registry subkeys that are listed in the reference table in this section. These registry subkeys may not contain a complete list of installed files. Also, these registry subkeys may not be created correctly when an administrator or an OEM integrates or slipstreams this security update into the Windows installation source files. "
    Thursday, March 27, 2014 3:06 PM