none
Move resources fails RRS feed

  • Question

  • Hi -

    I am trying to migrate resources between subscriptions and I keep running into an error saying the Resource Group can't be found.

    I tried just moving resources within the same subscription to a temp resource group and it still fails.


    The error message is:

    {"code":"ResourceMoveProviderValidationFailed","message":"Resource move validation failed. Please see details. Diagnostic information: timestamp '20190823T052113Z', subscription id '<removed>', tracking id '<removed>', request correlation id '<removed>'.","details":[{"target":"Microsoft.Web/sites","message":"{\"Code\":\"NotFound\",\"Message\":\"Cannot find ResourceGroup with name [Source-Resource-Group].\",\"Target\":null,\"Details\":[{\"Message\":\"Cannot find ResourceGroup with name [Source-Resource-Group].\"},{\"Code\":\"NotFound\"},{\"ErrorEntity\":{\"ExtendedCode\":\"51004\",\"MessageTemplate\":\"Cannot find {0} with name {1}.\",\"Parameters\":[\"ResourceGroup\",\"[Source-Resource-Group]\"],\"Code\":\"NotFound\",\"Message\":\"Cannot find ResourceGroup with name [Source-Resource-Group].\"}}],\"Innererror\":null}"}]}

    One odd thing I have noticed is that when I look at the 3 app services that live in this resource group they have slightly different names: "source-resource-group" and "Source-Resource-Group"

    Any ideas?


    Friday, August 23, 2019 5:28 AM

All replies

  • Please refer to "Move guidance for App Service resources" certain limitations are listed in the document. Could be one of this limitation blocking resource movement.

    Friday, August 23, 2019 7:11 AM
    Moderator
  • Ah interesting:

    App Service resources can only be moved from the resource group in which they were originally created. If an App Service resource is no longer in its original resource group, move it back to its original resource group. Then, move the resource across subscriptions.

    My app services violate this I think.. I don't remember if they were created in this same resource group. This subscription has had the billing owner changed and I may have  moved resources around. I don't know if it's possible to move it back to the original resource group since I probably deleted it. The resource group it lives in is the only one left in that subscription. 

    Is there any way around this limitation short of deleting and re-creating the app services?

    Friday, August 23, 2019 7:49 AM
  • "how to see if the App Service was previously in a different resource group and which one it was in."The simplest way you could see the current and previous Resource Group is by using the Azure PowerShell cmdlet Get-AzureRmResource  

    Get-AzureRmResource
       -ResourceId "/subscriptions/<SUB-ID>/resourceGroups/<RG-NAME>/resources"
      | select Name, ResourceType, ResourceGroupName, Tags
     

    For more details see - https://blogs.msdn.microsoft.com/benjaminperkins/2018/08/10/resource-move-validation-failed-cannot-move-azure-app-service/

    Friday, August 23, 2019 11:24 AM
    Moderator
  • Just checking in If the suggestions were helpful, click “Mark as Answer” and Up-Vote. Feel free to reach out to us if you've additional questions in this regard.
    Monday, August 26, 2019 9:53 AM
    Moderator