locked
Can not create a SqlCe Database in VS RRS feed

  • Question

  • Hi,
    This is crazy. I used to be able to create SqlCe Database in VS 2005 using this Method:

    1)  Data --> Add New Data Source

    Now, After I click as above, there is no response whatsoever. Tell me what's wrong with VS2005 and there are somethings missing?

    Please help.

    Thanks



    Peace is the fruit of Love
    Tuesday, March 9, 2010 12:38 PM

Answers

  • Hi BinaryWave,

    Sql ce 3.5 is for vs2008, not vs2005. So here we need to install vs2008 first. Note: only vs2008 professional or later version support wm development.

    For your last question:
    Q5) In my NetCF app that has Sql Mobile 2005, it is still running in VS2005 but I can not open it using Data -> Show Data source or  View -> Server explorer.

    I suggest you reset your PC and try again, I can't reproduce it in my local PC.


    Best regards,
    Guang-Ming Bian - MSFT
    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    Thursday, March 11, 2010 6:22 AM

All replies

  • Have you made changes to your workstation (like installing SQL Compact 3.5 for example)?
    Tuesday, March 9, 2010 2:56 PM
  • Hi,

    I have not installed Sql Compact 3.5.

    I have done the following checking:

    1) Check programs installed in Add/remove Program in Control panel.  I dont see any SqlCe 3.5 . I have SQL Mobile 2005 ( I believe it is SqlCe 3.0)

    2) I checked here  C:\Program Files\Microsoft Visual Studio 8\SmartDevices\SDK\SQL Server\Mobile

    It contains v2.0 and v3.0


    Questions:

    Q3) Will Microsoft Update Component  install automatically ? very often the System receive microsoft latest update. Is this the cause?


    Q4) Can you show me how and where to check if Sql Ce 3.5 override previous lower version sql ce?

    Q5) In my NetCF app that has Sql Mobile 2005, it is still running in VS2005 but I can not open it using Data -> Show Data source or  View -> Server explorer.


    Please help.


    Thanks


     




    Peace is the fruit of Love
    Wednesday, March 10, 2010 12:29 AM
  • Hi BinaryWave,

    Sql ce 3.5 is for vs2008, not vs2005. So here we need to install vs2008 first. Note: only vs2008 professional or later version support wm development.

    For your last question:
    Q5) In my NetCF app that has Sql Mobile 2005, it is still running in VS2005 but I can not open it using Data -> Show Data source or  View -> Server explorer.

    I suggest you reset your PC and try again, I can't reproduce it in my local PC.


    Best regards,
    Guang-Ming Bian - MSFT
    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    Thursday, March 11, 2010 6:22 AM