none
[SOLVED] My images are not accepting keyboard interrupt during the time of booting?? RRS feed

  • Question

  • Hello Friends,

     I am using AM335x BSP source code. Today, I have opened existing project out of various projects and selected required items from Catalog Items and build the images with KITL enabled for release build and build done successfully. When I inserted the images in the mSD card and connected the target device with host over Debug Serial Console. I am getting message from bootloader but when i press space key for menu options, its not stopping which means that it is not accepting keyboard interrupt.. I am confused about this since morning. Many times reboot the host machine, change the COM port over host machine, changed the cable... bla bla bla....

    My old images are working very much fine... Even that when i build the same project some days ago, it was working fine.......

    I need help to solve the problem...????


    Tuesday, September 16, 2014 12:57 PM

All replies

  • Hello Friends,

     I am using AM335x BSP source code. Today, I have opened existing project out of various projects and selected required items from Catalog Items and build the images with KITL enabled for release build and build done successfully.

    So, is there any reason to believe that this OS and previous OSs have much in common?  Do you use version control?  If not, start using version control.   If so, diff your current against previous versions.   What changed?

    Are you building on the same computer that you built the earlier OSs?  Or is it possible that the change is the setup/installation of the tools on a new PC?

    If I understand correctly, you are talking about the bootloader menu.  Bootloaders don't typically use interrupts, they poll and you should easily be able to find that code and debug it.

    The good news is that you have already narrowed this down to a change in your software.   So it should be fairly quick to determine what you changed.


    Bruce Eitman (eMVP) Senior Engineer Bruce.Eitman AT Eurotech DOT com My BLOG http://geekswithblogs.net/bruceeitman Eurotech Inc. www.Eurotech.com

    Tuesday, September 16, 2014 1:16 PM
    Moderator
  • Hello Sir,

    I would like to intimate you that the problem is solved now after building Full build option. The answer of your queries are-

    1. The version is same.

    2. The host system is also same.

    3. I learnt one thing from your reply that bootloader used polling rather then interrupts.

    4. I did not made any change.... 

    But, the way the problem solved is not the correct logic. Without making any chnage we can build the project in any build mode.........

    Tuesday, September 16, 2014 1:27 PM