locked
iOS simulator to Windows fails RRS feed

  • Question

  • User215198 posted

    I have installed the last version of iOS simulator for Windows on VS 2015 Update3 and it fails at startup. First on the iOS simulator for Windows, i can see:

    1. Connecting to Mac ...
    2. Checking server...
    3. Connected After a little time i see the complete frame with the menus and the central Apple icon and later the message box:

    Failed to install /Users/xxxx/Library/Caches/Xamarin/mtbs/builds/XamarinPortableiOS/bb4455981a4b47b86c93f2eee2 ddddd8/bin/iPhoneSimulator/Debug/XamarinPortableiOS.app to to OC9190C4-F507-41D8-9959-2B553FB9A64C

    I tried to delete the folder 'bb4455981a4b47b86c93f2eee2ddddd8' on my mac host and to launch a new Mac iOS simulator debug session from VS to reload the folder content. The whole folder is copied afresh and the Mac iOS simulator '4s iOS 9.3' works fine but when i am trying a new 'remote logging' the iOS simulator for Windows fails with the same message :(

    Tuesday, July 26, 2016 1:15 PM

All replies

  • User214819 posted

    I'm having the same problem did you find a solution ?

    Thursday, July 28, 2016 3:39 PM
  • User215198 posted

    Yes ! I had only 2Gb of RAM on my old MacMini(OS: ElCapitan), after upgrading to 8Gb all is working fine :) It seems that the MacOS needs too much memory to run a 'remote simulator' new session !?

    Thursday, July 28, 2016 4:03 PM
  • User215198 posted

    In fact on my Mac (MacMini - ElCapitan 10.11.5) a remote session of 'iOS Simulator' use : 3.10 GB of Memory + 2.60 GB of Cached Files For the initial use the Windows 'iOS remote simulator' seems very cool an easy to use :smiley:

    Thursday, July 28, 2016 4:27 PM
  • User242085 posted

    I don't think RAM is always the issue. I have 16gb of ram on my macbook. Check the activity monitor, there is only 5gb being used at the time I try to deploy using iPhoneSimulator on VS. Still, I get the same exact error. Is there absolutely no log file generated or ANY type of error/warning message?

    Also, I'm running Yosemite 10.10.5. Would that be an issue?

    Saturday, July 30, 2016 3:09 AM
  • User215198 posted

    Brandon have you try to delete the folder '/Users/xxxxxxx/Library/Caches/Xamarin/mtbs/builds/XamarinPortableiOS/yyyyyyyyyyyyyyyy/bin/iPhoneSimulator/Debug/zzzzz.app' on your Mac ? After the folder deletion the debugging system first creates afresh folder for you debugging application, writing the 'updating...' message on the remote simulator. Perhaps if it fails you will see some error messages on the Mac 'Console' tool filtering by 'Xamarin 4.1' !?

    Monday, August 1, 2016 7:24 AM
  • User138449 posted

    Found an answer here: http://stackoverflow.com/questions/37969145/xamarin-forms-ios-deploy-with-simulator-failed-to-install-error

    Thursday, October 6, 2016 11:44 PM
  • User245597 posted

    @SiavashGhassemi I follow your solution and put my mac user name as FullName, and reconnect mac with visual studio. Still getting same error. Any one found solution regarding this error.

    Monday, October 17, 2016 5:18 AM
  • User40046 posted

    I'm also experiencing this error. Changing my fullname to the username, but it didn't fix the issue.

    Sunday, November 13, 2016 1:20 AM
  • User1278 posted

    Anyone have luck with this issue. I am also having "Install Failed"

    Wednesday, March 8, 2017 3:18 PM
  • User298060 posted

    Hi Guys, I just downloaded VS2017 enterprise edition and connected to the mac agent, built the code, simulator came up and boom.. got the same error. Any one from the Xamarin team have any solutions/work arounds for this?

    Friday, March 10, 2017 12:01 PM
  • User398061 posted

    Hi folks, I know this is an old thread, but is it fair to say that the only good way of resolving this issue is to uninstall and reinstall everything on the mac and on windows? It seems to me that Xamarin still has a long way to go before it could be considered usable. I've managed to build and run 1 very basic app with Xamarin Forms and now i've hit this error and nothing seems to resolve it reliably.

    Saturday, November 21, 2020 2:04 PM