Extra sub-folders showing up in ftp window RRS feed

  • Question

  • User-81639759 posted

    On one of my Server 2012 R2 boxes (with IIS 8.5), I created a new  web site and added FTP publishing to the site. Then, I created a default.htm page for testing purposes. Next, I opened the FTP site in Windows Explorer and noticed additional folders and files (_private, _vti_log, App_Data, Images, _vti_inf.html, and postinfo.html) had been created. I went back to view the folders in a new Windows Explorer window, navigating to inetpub\wwwroot\site\ folder, and it does not appear. For some reason this only appears in the FTP window. If I'm not mistaken, these folders are automatically created when someone is using Frontpage Server Extensions (http://www.rtr.com/fpse/Win2008R2/index.htm). While I do have FPSE installed on the server, it is not extended on this particular site. Does anyone know why it occurs and if there is anything I can do to prevent it from occurring next time?

    Thursday, January 19, 2017 4:17 PM

All replies

  • User-460007017 posted

    Hi christopher,

    IIS http website and FTP website are different kind of things.

    This link provide the steps to set up FTP site:


    If you want to hide subfolder for user, I recommend you use user isolation. It could hide the folder for the specific user.

    Hope this link could help you understand the user isolation:


    Best Regards,

    Yuk Ding

    Friday, January 20, 2017 3:59 AM
  • User-81639759 posted

    I'm confused. I thought it was that way with IIS 6 but not 7 and above. According to https://www.iis.net/downloads/microsoft/ftp, "FTP for IIS 7.0 allows users to enable FTP for an existing Web site, instead  of creating separate FTP and Web sites to host the same content." I don't need user isolation. What's the difference between "add FTP publishing" and "add ftp site"?

    Monday, January 23, 2017 9:25 PM
  • User-460007017 posted

    Hi chrisopher8,

    I'm sorry that I have forgotten that the FTP could be added with FTP binding host header. I think the issue you are confused about is related to the request filter.

    There are FTP request filter and request filter in feature view. The hidden segment also control which could be hidden. If you want to display them, you could just navigate to IIS manager->request filter->hidden segments and remove the segment you doesn't need.

    Best Regards,

    Yuk Ding

    Tuesday, January 24, 2017 8:02 AM