none
TS session disconnects after the session is idle for a few minutes RRS feed

  • Question

  • This happens when connecting to a RDP session of a windows2012 VM on Azure using the latest RDP client and al recent updates.

    We tried TS keep alive GPO but this setting made it more worse, The RDP client crashed or completely freeze for a couple of minutes.

    We also tried to disable the network auto tuning option by command without success (as suggested on different forums): netsh interface tcp set global autotuninglevel=disabled

    We figured out that this problem is related to windows server2012

    When using server 2008 r2 terminal server sessions in the same domain with the same GPO's and the same netword the session stays connected.

    If anyone can help me out please give me some suggestions

    Extra info after more testing :

    Server 2008 without TS keepalive also disconnects, after setting up GPO on server 2008 it looks good but the same GPO on server 2012 interups the session realy hard (sometimes hard reset with taskmanager is needed).

    I think disconnection is done by routers, with TS keepalive this is solved on server 2008 but it interups a server2012 session, so bug in tsclient ?





    Thursday, December 20, 2012 11:03 PM

All replies

  • I cannot connect to any 2012 VM in Azure after the initial setup. I have asked MS for help but they are hiding behind the "In Preview" screen. After creating and setting up a VM and being able to connect, if we logout and come back the next day we can no longer connect. I am going to try see if a 2008 VM works better. I am getting paid very large sums of retainer an hour by a very big client (4500 employees) to report back on setting up VMs in Azure and I am on the verge of telling them to try someone else (like Amazon) until MS comes clean on what the issues are.


    Friday, December 21, 2012 11:21 AM
  • Jeffrey,

    At the moment we have 5x 2012VM's live, so this normaly works.

    We had taken the folowing steps (in common to setup a virtual environment):

    1. Create affinity groep
    2. Create virtual network
      1. Name: xxx
      2. Subnet 10.0.0.0/24
      3. Backend 10.0.0.0/24
      4. Dns 10.0.0.4
    3. Create Storage
      1. Cloudos01
      2. Enable geo-replication
    4. Create VM
      1. From gallery
      2. Server 2012
      3. Name: xxx
      4. PW: yyy
      5. Standalone
      6. Dns: <<name>>.cloudapp.net
      7. Storageaccount: cloudos1
      8. Network: <<created network>>
      9. Create availability set: optional

    (this are notes from a few weeks ago, maybe it helps you a step further, if you want we can help you later on, give me a PM)

    Friday, December 21, 2012 1:04 PM
  • My 2008 VM seems to be staying connectable. The connect button on all my 2012 VMs gets grayed out. So it may be this is a 2012 issue.
    Tuesday, December 25, 2012 12:15 PM