none
Opening an excel sheet (.xlsm) from a HTTPS site in IE is asking for a windows security select a certificate prompt RRS feed

  • Question


  • I have an issue with Excel and IE.  When I am trying to open a .xlsm file from a https website by clicking on File>Open With, it pops up a windows asking me to "Choose a digital certificate" with certs listed by the name : myname@mycompanyname.com and Issuer: Communications Server . I have to click on ok several times still it does not open the file. The site is using HTTPS. The strange thing is that I can open the file if I use FireFox.

    Any help would be appreciated.....

    Please help !!

     





    • Edited by nan_09 Saturday, November 12, 2016 1:21 PM
    Friday, November 11, 2016 2:33 PM

All replies

  • Hi nan_09,

    you had mentioned that you are trying to open excel file using IE.

    can you tell us where you stored Excel file? is it stored on the cloud or in some website?

    if possible then you can try to store there a demo file and provide us a link so that we can try to open that demo file using IE and can reproduce the issue on our end.

    you can try to implement below mentioned suggestions may solve your issue.

    User can add the desired site to the Trusted list, and set the URLAction in the Trusted zone to Enable.

    For more detail information please visit the link mentioned below.

    Client Certificate Selection Prompt

    if that doesn't work then try the below mentioned approach.

    • Clicked on Tools
    • Clicked on Internet Options
    • Clicked Advanced
    • Scrolled down to "Check for publisher's certificate revocation." and unchecked this.
    • Clicked Apply
    • Clicked OK
    • Closed IE

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Monday, November 14, 2016 5:35 AM
    Moderator
  • Hi,

    The excel file is stored in our website. It is not in cloud.

    Regards, 

    Monday, November 14, 2016 9:41 AM
  • Hi nan_09,

    did you implement the suggestion I suggest you last time?

    if yes, what result you get after that? please inform us.

    if you did not implement that till now please try to implement that first.

    which version of IE you are using currently?

    does your excel file opens using Excel online?

    please provide the detailed information.

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, November 14, 2016 9:54 AM
    Moderator
  • Hi, The IE version we are using is IE 11.  This certificate popup is coming only in some instances i.e. when we are checking with few PC. In other PC it is working fine. We want this certificate popup to not appear at all.  
    • Edited by nan_09 Monday, November 14, 2016 11:38 AM
    Monday, November 14, 2016 11:32 AM
  • Hi,

    The above suggestion did not work. I tried the below but it did not work.

    • Clicked on Tools
    • Clicked on Internet Options
    • Clicked Advanced
    • Scrolled down to "Check for publisher's certificate revocation." and unchecked this.
    • Clicked Apply
    • Clicked OK
    • Closed IE

    Monday, November 14, 2016 12:36 PM
  • Hi nan_09,

    you had mentioned that some pcs are affected and some are working fine.

    did you try to check the difference of the settings that are saved for the IE.

    are all the settings in the IE are same?

    I again want to confirm with you are you open the file using excel online?

    if not then how you are opening the file in IE.

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, November 15, 2016 8:37 AM
    Moderator
  • Hi,

    The excel files are not opening in every PC. Every PC is asking for a windows security select a certificate pop up. And on clicking ok it does not open the excel sheet. I have tried changing the settings of IE as mentioned by you above but that did not work. The security certificate is coming where ever we are opening the excel file in IE 11.         

    Tuesday, November 15, 2016 9:13 AM
  • Hi nan_09,

    at this stage it looks like there is no problem with Excel file but the problem is with IE Application.

    I discuss with Internet Explorer Support Team.

    They gave me the below mentioned suggestion that you can try.

    "open IE, click Tools, Internet Options, and then select the Security tab. Select the zone associated with your application’s Web site and click Custom level. Find the Don’t prompt for client certificate selection when no certificates or only one certificate exists option and enable it. Now users will no longer be prompted because IE will automatically select their client certificate and use it to access the Web site.  "

    also they suggest me a link that you can refer.

    Internet Explorer 11- issue with security certificate error prompt

    if then also your issue exist then to get accurate suggestion regarding certificate popup in IE I suggest you to post the question in Internet Explorer forum.

    MSDN Internet Explorer Forum

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, November 16, 2016 9:30 AM
    Moderator