locked
Where did my TFS Windows Shell extension icons go? RRS feed

  • Question

  • I have the latest TFPT installed but after doing some configuration changes in Team Explorer I have lots my Windows Explorer TFS status icons. I can still right click on files that are in my workspace and the Team Foundation Server context menu shows up, but the icons are gone.  I have tried repairing the Power Tools installation, restarting Windows, but no luck. There aren't any configuration settings for these icons anywhere are there?
    Friday, October 2, 2009 10:52 PM

Answers

  • It is fixed! I checked out this folder in the registry: HKLM\\SOFTWARE\\Microsoft\\Windows\\CurrentVersion\\Explorer\\ShellIconOverlayIdentifiers and there were items in there from Dropbox and MS Groove. Uninstalled both of those and all my TFS icons are working again. Its an unfortunate limitation in Windows that you can only have 16 icon overlays at once.
    • Marked as answer by Luke15612 Monday, October 5, 2009 5:28 PM
    Monday, October 5, 2009 5:26 PM

All replies

  • Hi Luke

    A quick suggestion, is it help if you remove the Windows Shell Extension feature of the power tool, then reinstall this feature? 

     

    Bill Wang

    MSDN Subscriber Support in Forum

    If you have any feedback on our support, please contact msdnmg[at]microsoft.com.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Monday, October 5, 2009 5:42 AM
  • Hmm.. I tried removing and reinstalling, one strange thing was that it prompted me that 3 processes were still running when I did the remove, TfsComProviderSvr, TfsCommand-something and Windows Explorer. Seems wrong to get a warning about Windows Explorer, ended up killing all 3 processes in order to proceed. Restarted and still no icons. Also tried removing and re-adding workspace mappings but that didn't help. I think I'll try removing Team Explorer as well this time.
    Monday, October 5, 2009 4:20 PM
  • Looks like it was probably a conflict with SmartSVN that I had recently installed. Uninstalled SmartSVN and now things are kinda working -- overlays show up in the folder tree on the left side of explorer but not in the main view. Still no overlays on actual files either. Yargh
    Monday, October 5, 2009 4:53 PM
  • It is fixed! I checked out this folder in the registry: HKLM\\SOFTWARE\\Microsoft\\Windows\\CurrentVersion\\Explorer\\ShellIconOverlayIdentifiers and there were items in there from Dropbox and MS Groove. Uninstalled both of those and all my TFS icons are working again. Its an unfortunate limitation in Windows that you can only have 16 icon overlays at once.
    • Marked as answer by Luke15612 Monday, October 5, 2009 5:28 PM
    Monday, October 5, 2009 5:26 PM
  • Or put this in the command line: reg query HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ShellIconOverlayIdentifiers

    Btw, Groove is part of the Office suite and can be uninstalled via the Office setup: http://support.microsoft.com/kb/907504

    When using Office 2010 the setup may not offer you uninstalling Groove. In this case delete the Groove icon overlay registry entries and kill explorer.exe and start explorer.exe again and you'll see the icon overlays now.


    • Proposed as answer by hfrmobile Monday, October 17, 2011 11:11 AM
    • Edited by hfrmobile Monday, October 17, 2011 11:12 AM
    Monday, October 17, 2011 11:05 AM