locked
Exception in Visual studio RRS feed

  • Question

  • Could you please explain me about this error.

    An unhandled Microsoft .NET framewok exception occured in devenv.exe [18204]"

    Monday, February 17, 2014 4:32 AM

Answers

  • Hi,

    Could you please tell us the version of your VS and .NET framework?

    Please use /Log command line.

    /Log (devenv.exe) :

    Logs all activity to the log file for troubleshooting. This file appears after you have called devenv /log at least once. By default the log file is:

    %APPDATA%\ Microsoft\VisualStudio\<version>\ActivityLog.xml. However, you may specify an alternate path and file name.

    where <version> is the Visual Studio version.

    Devenv /log <path/name of log file>

    This switch must appear at the end of the command line, after all other switches.

    The log is written for all instances of Visual Studio that you have invoked with the /log switch. It does not log instances of Visual Studio that you have invoked without the switch.

    Moreover, here is a similar thread that you can follow the steps there.

    http://social.msdn.microsoft.com/Forums/en-US/f43af99e-33a1-4100-90a6-cce2f62501c5/unhandled-microsoft-net-framework-exception-occurred-in-devenvexe4772?forum=vssetup

    If they can not help you, please try uninstall and reinstall your plugin. I guess there is something wrong with your plugin. If it doesn't work, please provide us with details about your plugin.

    Best regards,

    Sunny



    • Edited by Anna Cc Wednesday, February 19, 2014 2:40 AM
    • Marked as answer by Anna Cc Tuesday, February 25, 2014 1:56 AM
    Wednesday, February 19, 2014 2:29 AM

All replies

  • Hi,

    Could you please tell us that how you get that error?

    Just start visual studio, or run your application?

    Best regards,

    Sunny

    Monday, February 17, 2014 8:06 AM
  • Hi Sunny,

    Not on running visual studio.  I have source code control plugin enabled, some times this message is coming as pop up. If I disable the plugin, it is not occuring no more . Could you please explain about this error

    Monday, February 17, 2014 8:19 AM
  • Hi,

    >> I have source code control plugin enabled, some times this message is coming as pop up.

    Please type "devenv /resetsettings" in cmd. Please refer to /ResetSettings (devenv.exe).

    If it can not help you, please get the log file when this message appears. It will help us to analyse this error. I guess it mainly related with the plugin.

    Best regards,

    Sunny

     

    Monday, February 17, 2014 10:39 AM
  • Hi Sunny ,

    Can you tell me log file location ?

    Monday, February 17, 2014 10:42 AM
  • Hi,

    Could you please tell us the version of your VS and .NET framework?

    Please use /Log command line.

    /Log (devenv.exe) :

    Logs all activity to the log file for troubleshooting. This file appears after you have called devenv /log at least once. By default the log file is:

    %APPDATA%\ Microsoft\VisualStudio\<version>\ActivityLog.xml. However, you may specify an alternate path and file name.

    where <version> is the Visual Studio version.

    Devenv /log <path/name of log file>

    This switch must appear at the end of the command line, after all other switches.

    The log is written for all instances of Visual Studio that you have invoked with the /log switch. It does not log instances of Visual Studio that you have invoked without the switch.

    Moreover, here is a similar thread that you can follow the steps there.

    http://social.msdn.microsoft.com/Forums/en-US/f43af99e-33a1-4100-90a6-cce2f62501c5/unhandled-microsoft-net-framework-exception-occurred-in-devenvexe4772?forum=vssetup

    If they can not help you, please try uninstall and reinstall your plugin. I guess there is something wrong with your plugin. If it doesn't work, please provide us with details about your plugin.

    Best regards,

    Sunny



    • Edited by Anna Cc Wednesday, February 19, 2014 2:40 AM
    • Marked as answer by Anna Cc Tuesday, February 25, 2014 1:56 AM
    Wednesday, February 19, 2014 2:29 AM